b461a0649f
- Unbreak the build on PowerPC by adding -fsigned-char to CFLAGS (and also respect them by removing hardcoded -O3) - Rename a patch and regenerate it with `make makepatch' command - Clean up do-install target (sanitize symlink, wrap overly long line) - Reformat and kill EOL whitespace in the port description text
40 lines
867 B
Text
40 lines
867 B
Text
--- src/Makefile.orig 2013-06-18 12:49:36 UTC
|
|
+++ src/Makefile
|
|
@@ -1,9 +1,10 @@
|
|
-LIBRARIES = libb64.a
|
|
+LIBRARIES = libb64.a libb64.so
|
|
+SOVERSION ?= 0
|
|
|
|
# Build flags (uncomment one)
|
|
#############################
|
|
# Release build flags
|
|
-CFLAGS += -O3
|
|
+#CFLAGS += -O3
|
|
#############################
|
|
# Debug build flags
|
|
#CFLAGS += -g
|
|
@@ -15,7 +16,7 @@ TARGETS = $(LIBRARIES)
|
|
|
|
LINK.o = gcc
|
|
|
|
-CFLAGS += -Werror -pedantic
|
|
+CFLAGS += -Werror -pedantic -fsigned-char
|
|
CFLAGS += -I../include
|
|
|
|
vpath %.h ../include/b64
|
|
@@ -27,6 +28,15 @@ all: $(TARGETS) #strip
|
|
libb64.a: cencode.o cdecode.o
|
|
$(AR) $(ARFLAGS) $@ $^
|
|
|
|
+libb64.so.$(SOVERSION): cencode.So cdecode.So
|
|
+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$@ -o $@ $^
|
|
+
|
|
+%.So: %.c
|
|
+ $(CC) -fPIC -c $(CFLAGS) $(CPPFLAGS) $< -o $@
|
|
+
|
|
+%.so: %.so.$(SOVERSION)
|
|
+ ln -fs $< $@
|
|
+
|
|
strip:
|
|
strip $(BINARIES) *.exe
|
|
|