29 lines
1.1 KiB
Text
29 lines
1.1 KiB
Text
--- libmysql/CMakeLists.txt.orig 2018-03-09 22:41:36 UTC
|
|
+++ libmysql/CMakeLists.txt
|
|
@@ -235,7 +235,7 @@
|
|
ADD_SUBDIRECTORY(authentication_ldap)
|
|
|
|
# Merge several convenience libraries into one big perconaserverclient
|
|
-MERGE_CONVENIENCE_LIBRARIES(perconaserverclient ${LIBS} COMPONENT Development)
|
|
+MERGE_CONVENIENCE_LIBRARIES(perconaserverclient ${LIBS} COMPONENT Development SKIP_INSTALL)
|
|
|
|
# Visual Studio users need debug static library for debug projects
|
|
IF(MSVC)
|
|
@@ -271,7 +271,8 @@
|
|
# and link them together into shared library.
|
|
MERGE_LIBRARIES_SHARED(libmysql ${LIBS}
|
|
EXPORTS ${CLIENT_API_FUNCTIONS} ${CLIENT_API_FUNCTIONS_UNDOCUMENTED}
|
|
- COMPONENT SharedLibraries)
|
|
+ COMPONENT SharedLibraries SKIP_INSTALL)
|
|
+IF(FALSE)
|
|
IF(UNIX)
|
|
# libtool compatability
|
|
IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD" OR APPLE)
|
|
@@ -327,6 +328,7 @@
|
|
# to initialize api_calls[] array in api_test.c
|
|
#
|
|
SET(CLIENT_API_FUNCTION_LIST "")
|
|
+ENDIF()
|
|
FOREACH(api ${CLIENT_API_FUNCTIONS})
|
|
SET(CLIENT_API_FUNCTION_LIST "${CLIENT_API_FUNCTION_LIST} ${api},")
|
|
ENDFOREACH()
|