KDE's April 2020 Apps Update A new bundle of KDE applications is here! In these releases, you can expect to find more features, stability improvements, and more user-friendly tools that will help you work more effectively. There are dozens of changes to look forward to in most of your favorite applications. Take Dolphin, for example. Windows Samba shares are now fully discoverable. On the topic of playing music: the Elisa music player is adding features by leaps and bounds. This release brings a new “Now Playing” view, easy accessibility through the system tray, and an option to minimize the playlist whenever you want. Thanks to the recently-added visual shuffle mode, it’s much easier to rearrange your music in the playlists. These are just the highlights of what’s new in KDE’s applications this month. Read on to find out about everything we’ve prepared for you. Announcement: https://kde.org/announcements/releases/2020-04-apps-update/
47 lines
1.7 KiB
Text
47 lines
1.7 KiB
Text
--- CMakeLists.txt.orig 2020-03-19 23:24:52 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -81,24 +81,28 @@ set_package_properties("libssh" PROPERTIES
|
|
PURPOSE "Needed to build VNC+SSH tunnel support "
|
|
)
|
|
|
|
-# Needs porting
|
|
-find_program(FREERDP_EXECUTABLE xfreerdp)
|
|
-if(FREERDP_EXECUTABLE)
|
|
- set(FREERDP_FOUND true) # mark the package found
|
|
- set(FREERDP_EXECUTABLE_FOUND true)
|
|
-endif(FREERDP_EXECUTABLE)
|
|
+option(WITH_FREERDP OFF)
|
|
+if (WITH_FREERDP)
|
|
+ # Needs porting
|
|
+ find_program(FREERDP_EXECUTABLE xfreerdp)
|
|
+ if(FREERDP_EXECUTABLE)
|
|
+ set(FREERDP_FOUND true) # mark the package found
|
|
+ set(FREERDP_EXECUTABLE_FOUND true)
|
|
+ endif(FREERDP_EXECUTABLE)
|
|
|
|
-# dud to allow the dep showing up in feature summary.
|
|
-# note that this must be after _FOUND is set so it doesn't incorrectly
|
|
-# set the metadata to not-found.
|
|
-find_package(freerdp QUIET)
|
|
+ # dud to allow the dep showing up in feature summary.
|
|
+ # note that this must be after _FOUND is set so it doesn't incorrectly
|
|
+ # set the metadata to not-found.
|
|
+ find_package(freerdp QUIET)
|
|
|
|
-set_package_properties(freerdp PROPERTIES
|
|
- DESCRIPTION "A free Remote Desktop Protocol (RDP) Implementation"
|
|
- URL "https://www.freerdp.com/"
|
|
- PURPOSE "The xfreerdp binary is needed for RDP support in KRDC (at runtime)"
|
|
- TYPE RUNTIME
|
|
-)
|
|
+ set_package_properties(freerdp PROPERTIES
|
|
+ DESCRIPTION "A free Remote Desktop Protocol (RDP) Implementation"
|
|
+ URL "https://www.freerdp.com/"
|
|
+ PURPOSE "The xfreerdp binary is needed for RDP support in KRDC (at runtime)"
|
|
+ TYPE RUNTIME
|
|
+ )
|
|
+endif()
|
|
+
|
|
if (EXISTS "${CMAKE_SOURCE_DIR}/.git")
|
|
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x060000)
|
|
endif()
|