freebsd-ports/x11-toolkits/ocaml-labltk/files/patch-lib_Makefile
Guido Falsi cb214a8a7b Objective Caml interface to Tk
LablTk is an interface to the Tcl/Tk GUI framework. It allows to
develop GUI applications in a speedy and type safe way. A legacy
Camltk interface is included. The OCamlBrowser library viewer is
also part of this project.

WWW: https://forge.ocamlcore.org/projects/labltk/

PR:		195737
Submitted by:	Michael Grunewald <michipili at gmail.com>
2015-05-04 15:39:41 +00:00

18 lines
614 B
Text

--- lib/Makefile.orig 2014-09-18 04:08:33 UTC
+++ lib/Makefile
@@ -75,7 +75,7 @@ $(LIBNAME)top$(EXE) : $(LIBNAME).cma ../
$(LIBNAME): Makefile
@echo Generate $@
@echo "#!/bin/sh" > $@
- @echo 'exec $(INSTALLDIR)/$(LIBNAME)top$(EXE) -I $(INSTALLDIR) "$$@"' >> $@
+ @echo 'exec %%SCRIPTBASE%%/$(LIBNAME)top$(EXE) -I %%SCRIPTBASE%% "$$@"' >> $@
install-script: $(LIBNAME)
cp $(LIBNAME) $(INSTALLBINDIR)
@@ -114,4 +114,4 @@ installopt:
cd $(INSTALLDIR); $(RANLIB) $(LIBNAME).$(A)
chmod 644 $(INSTALLDIR)/$(LIBNAME).cmxa
chmod 644 $(INSTALLDIR)/$(LIBNAME).$(A)
-endif
\ No newline at end of file
+endif