b64244312f
odbc-cpp-wrapper is an object-oriented C++-wrapper of the ODBC API. It takes care of - managing the lifetime of ODBC resources, - allocating and managing resources needed for ODBC operations and - converting ODBC errors to exceptions and throwing them. The odbc-cpp-wrapper API attempts to make usage of ODBC as simple as possible. The API was designed to make wrong usage almost impossible and to ensure proper object lifetime management. odbc-cpp-wrapper was originally developed for exchanging spatial data with databases. It focuses on batch operations of variable-sized data, which is not very well supported by other ODBC wrappers.
20 lines
397 B
Text
20 lines
397 B
Text
--- CMakeLists.txt.orig 2022-09-13 10:33:43 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -5,17 +5,9 @@ SET(CMAKE_CXX_STANDARD 11)
|
|
PROJECT(odbccpp)
|
|
|
|
FIND_PACKAGE(ODBC REQUIRED)
|
|
-FIND_PACKAGE(Doxygen)
|
|
-FIND_PACKAGE(GTest)
|
|
|
|
FILE(STRINGS cfg/VERSION version)
|
|
|
|
ENABLE_TESTING()
|
|
|
|
ADD_SUBDIRECTORY(src)
|
|
-IF (GTEST_FOUND)
|
|
- ADD_SUBDIRECTORY(test)
|
|
-ENDIF()
|
|
-IF (DOXYGEN_FOUND)
|
|
- ADD_SUBDIRECTORY(doc)
|
|
-ENDIF()
|