freebsd-ports/databases/odbc-cpp-wrapper/files/patch-src-odbc-CMakeLists.txt
Po-Chuan Hsieh b64244312f
databases/odbc-cpp-wrapper: Add odbc-cpp-wrapper 1.1
odbc-cpp-wrapper is an object-oriented C++-wrapper of the ODBC API. It takes
care of
- managing the lifetime of ODBC resources,
- allocating and managing resources needed for ODBC operations and
- converting ODBC errors to exceptions and throwing them.

The odbc-cpp-wrapper API attempts to make usage of ODBC as simple as possible.
The API was designed to make wrong usage almost impossible and to ensure proper
object lifetime management.

odbc-cpp-wrapper was originally developed for exchanging spatial data with
databases. It focuses on batch operations of variable-sized data, which is not
very well supported by other ODBC wrappers.
2022-10-03 10:10:12 +08:00

10 lines
357 B
Text

--- src/odbc/CMakeLists.txt.orig 2022-08-05 08:39:29 UTC
+++ src/odbc/CMakeLists.txt
@@ -57,6 +57,7 @@ TARGET_COMPILE_DEFINITIONS(odbccpp_static
ODBC_STATIC
)
SET_PROPERTY(TARGET odbccpp_static PROPERTY POSITION_INDEPENDENT_CODE ON)
+SET_TARGET_PROPERTIES(odbccpp_static PROPERTIES OUTPUT_NAME "odbccpp")
# Shared library
ADD_LIBRARY(odbccpp