d61c8722b2
- License of runtime libraries changed to GPLv2 + linking exception. Some headers and libraries for Microchip PIC devices are generated from MPLAB include files and have the additional restriction that they may only be used with authentic Microchip devices. These headers and libraries have been moved into separate directories. You can add these directories to the compiler's search path with the --use-non-free command line option. - Improvements to register allocation. - Various bug fixes. [1] Remove the explicit passing of CPPFLAGS to CONFIGURE_ENV which is no longer necessary. [2] Submitted by: tijl (maintainer) [1] PR: 155762 [1], 153625 [2]
32 lines
1.1 KiB
Text
32 lines
1.1 KiB
Text
--- device/non-free/lib/Makefile.in.orig
|
|
+++ device/non-free/lib/Makefile.in
|
|
@@ -397,17 +397,6 @@
|
|
# ---------------------------------------------------
|
|
install: all installdirs
|
|
[ ! -d "$(BUILDDIR)" ] || $(CP_U) -r $(BUILDDIR)/* $(sdcc_libdir)
|
|
- $(CP_U) -r $(srcdir)/pic14 $(srcdir)/pic16 $(sdcc_libdir)/src
|
|
-
|
|
- for src in pic14 pic16; do \
|
|
- find $(sdcc_libdir)/src/$$src -depth \
|
|
- \( -name '*.rel' -o -name '*.dump*' -o -name '*.sym' -o -name '*.o' -o -name '*.lib' -o \
|
|
- -name '*.lst' -o -name '*.asm' -o -name '.svn' -o -name 'autom4te.cache' -o \
|
|
- -name 'build' -o -name 'bin' -o -name 'Makefile*' -o -name 'config*' -o \
|
|
- -name 'depcomp' -o -name 'missing' -o -name 'install-sh' -o \
|
|
- -name 'bootstrap.sh' \) \
|
|
- -exec rm -rf {} + ; \
|
|
- done
|
|
|
|
# Deleting all the installed files
|
|
# --------------------------------
|
|
@@ -427,10 +416,7 @@
|
|
# Creating installation directories
|
|
# ---------------------------------
|
|
installdirs:
|
|
- for libdir in pic16 pic14; do \
|
|
- mkdir -p $(sdcc_libdir)/$$libdir; \
|
|
- done
|
|
- mkdir -p $(sdcc_libdir)/src
|
|
+ mkdir -p $(sdcc_libdir)
|
|
|
|
# Creating dependencies
|
|
# ---------------------
|