e2ca6bea49
Cal3D is a skeletal based 3D character animation library written in C++ in a way that is both platform-independent and graphics API-independent. It was originally designed to be used in a 3D client for Worldforge, but evolved into a stand-alone product which can be used in many different kinds of projects. Cal3D's essentials can be boiled down to 2 parts: the C++ library and the exporter. The exporter is what you would use to take your characters (built in a 3D modeling package) and create the Cal3D-format files that the library knows how to load. The exporters are actually plug-ins for 3D modeling packages. This allows 3D artists to use the modeling tools that they're already comfortable with. The C++ library is what you would actually use in your application, whether it's a game or a VR application. The library provides methods to load your exported files, build characters, run animations, and access the data necessary to render them with 3D graphics. PR: ports/68954 Submitted by: Stefan Walter <sw@gegenunendlich.de>
12 lines
326 B
Text
12 lines
326 B
Text
--- src/cal3d/Makefile.am.orig Mon Jul 12 17:34:29 2004
|
|
+++ src/cal3d/Makefile.am Mon Jul 12 17:35:04 2004
|
|
@@ -13,7 +13,8 @@
|
|
INCLUDES = $(all_includes) -I$(top_srcdir)/src
|
|
|
|
all_libraries = @all_libraries@
|
|
-LDFLAGS = @LDFLAGS@
|
|
+#LDFLAGS = @LDFLAGS@
|
|
+AM_LDFLAGS = @AM_LDFLAGS@
|
|
|
|
EXTRA_DIST = cal3d.rc cal3d.dsp SConscript
|
|
|