freebsd-ports/ports-mgmt/porttools/files/patch-Makefile
Chris Rees 868c3b683e - Improve the heuristic for finding the port's directory name:
- If applicable, use CVS/Repository as the source of the port's
   directory name,
 - else try to fall back to the basename of the working directory
   if the PORTNAME heuristic fails.
 - The patches also fix
   <http://sourceforge.net/support/tracker.php?aid=1969774>.
- Add CVSauto as a new diff mode:
 - Handle added/deleted files without having to cvs add/delete them.
 - Works with :pserver:anoncvs@anoncvs.fr.freebsd.org.
 - When submitting you're asked to use "port submit -L" if files are
   added or deleted, because that's FATAL for portlint.
- Don't use the full path of the working directory in diffs.
- Include a port's PORTEPOCH in update mode in the generated PR.
- To aid in debugging porttools include this information in the PR:
 - porttools' PORTREVISION and PORTEPOCH (if defined),
 - submit and diff mode used by the submitter.
- Bump PORTREVISION.
- Pass maintainership to submitter

PR:		ports/139872
Submitted by:	Johannes 5 Joemann <joemann@beefree.free.de>
2012-03-03 13:31:02 +00:00

29 lines
849 B
Text

--- ./Makefile.orig 2009-09-09 21:59:59.000000000 +0200
+++ ./Makefile 2011-11-23 23:11:14.000000000 +0100
@@ -9,6 +9,15 @@
PORTNAME?= porttools
PORTVERSION?= 0.99
DISTNAME?= ${PORTNAME}-${PORTVERSION}
+.if defined(PORTREVISION) && defined(PORTEPOCH)
+VERSIONSTRING= ${PORTVERSION}_${PORTREVISION},${PORTEPOCH}
+.elif defined(PORTREVISION)
+VERSIONSTRING= ${PORTVERSION}_${PORTREVISION}
+.elif defined(PORTEPOCH)
+VERSIONSTRING= ${PORTVERSION},${PORTEPOCH}
+.else
+VERSIONSTRING= ${PORTVERSION}
+.endif
PROGRAMS= port
SCRIPTS= cmd_commit cmd_create cmd_diff cmd_fetch cmd_getpr cmd_help \
@@ -31,8 +40,8 @@
.SUFFIXES: .in
-.in:
- sed -e 's,__VERSION__,${PORTVERSION},;s,__PREFIX__,${PREFIX},' \
+.in:
+ sed -e 's%__VERSION__%${VERSIONSTRING}%;s,__PREFIX__,${PREFIX},' \
inc_header.in ${.IMPSRC} > ${.TARGET}
chmod a+x ${.TARGET}