71213a2872
- Transfer maintainership PR: ports/81254 Submitted by: Johan van Selst <johans@stack.nl> Approved by: David H. Munro <munro@oldben.llnl.gov> (maintainer)
20 lines
863 B
Text
20 lines
863 B
Text
--- yorick/Makefile.orig Sun May 15 11:30:16 2005
|
|
+++ yorick/Makefile Sun May 15 11:31:25 2005
|
|
@@ -16,7 +16,8 @@ OBJS = opsv.o task.o yorick.o yinput.o p
|
|
array.o range.o ops.o ops0.o ops1.o ops2.o ops3.o nonc.o debug.o \
|
|
std0.o std1.o std2.o ascio.o defmem.o yhash.o yrdwr.o bcast.o \
|
|
binio.o binobj.o binstd.o cache.o convrt.o binpdb.o clog.o ystr.o \
|
|
- graph.o graph0.o style.o list.o pathfun.o autold.o fortrn.o
|
|
+ graph.o graph0.o style.o list.o pathfun.o autold.o fortrn.o \
|
|
+ ywrap.o yinit.o
|
|
|
|
PKG_CLEAN=libyor main.c prmtyp.h codger lib$(PKG_NAME).a $(PKG_EXENAME) yorapi*
|
|
|
|
@@ -60,6 +61,7 @@ libyor: $(BUILTIN_PKGS)
|
|
cd ../matrix; $(MAKE) "COPT=$(COPT)" oinsert
|
|
cd ../fft; $(MAKE) "COPT=$(COPT)" oinsert
|
|
touch $@
|
|
+ $(AR) r ../yorick/libyor.a $(OBJS)
|
|
../gist/libgist.a:
|
|
@cd ../gist; $(MAKE) "COPT=$(COPT)" libgist.a
|
|
../regexp/libyor:
|