freebsd-ports/databases/mariadb101-server/files/patch-sql_CMakeLists.txt
Bernard Spil eaba6fd276 [NEW PORTS] databases/mariadb101-{server,client}: 10.1.11
MariaDB is one of the most popular database servers in the world. It's made
by the original developers of MySQL and guaranteed to stay open source.
Notable users include Wikipedia, Facebook and Google.

MariaDB turns data into structured information in a wide array of
applications, ranging from banking to websites. It is an enhanced, drop-in
replacement for MySQL. MariaDB is used because it is fast, scalable and
robust, with a rich ecosystem of storage engines, plugins and many other
tools make it very versatile for a wide variety of use cases.

MariaDB is developed as open source software and as a relational database
it provides an SQL interface for accessing data. This latest versions of
MariaDB also include GIS and JSON features.

WWW: http://mariadb.org/

Reviewed by:	koobs (mentor), feld (mentor)
Approved by:	koobs (mentor), feld (mentor)
Differential Revision:	D3953
2016-02-13 19:02:11 +00:00

30 lines
860 B
Text

Fix up missing WITHOUT_DOCS, WITHOUT_CLIENT options
--- sql/CMakeLists.txt.orig 2015-10-15 15:43:45 UTC
+++ sql/CMakeLists.txt
@@ -340,6 +340,7 @@ ADD_CUSTOM_TARGET(distclean
VERBATIM
)
+IF(FALSE)
IF(INSTALL_LAYOUT STREQUAL "STANDALONE")
# Copy db.opt into data/test/
@@ -383,6 +384,7 @@ ELSE()
INSTALL(FILES ${DUMMY_FILE} DESTINATION data/mysql COMPONENT DataFiles)
ENDIF(WIN32 AND MYSQLD_EXECUTABLE)
ENDIF(INSTALL_LAYOUT STREQUAL "STANDALONE")
+ENDIF()
IF(WIN32)
SET(my_bootstrap_sql ${CMAKE_CURRENT_BINARY_DIR}/my_bootstrap.sql)
@@ -425,7 +427,9 @@ IF(WIN32)
TARGET_LINK_LIBRARIES(mysql_upgrade_service mysys winservice)
ENDIF(WIN32)
+IF(FALSE)
INSTALL(DIRECTORY . DESTINATION ${INSTALL_INCLUDEDIR}/private COMPONENT Development
FILES_MATCHING PATTERN "*.h"
PATTERN share EXCLUDE
PATTERN CMakeFiles EXCLUDE)
+ENDIF()