bed724d50f
PR: 129909 Submitted by: myself Approved by: Alex Kozlov <spam at rm-rf dot kiev dot ua> (maintainer)
18 lines
509 B
Text
18 lines
509 B
Text
--- fuse_module/Makefile.orig 2008-02-05 08:25:57.000000000 +0300
|
|
+++ fuse_module/Makefile 2009-01-14 00:29:13.000000000 +0300
|
|
@@ -1,3 +1,5 @@
|
|
+.undef KERNCONF
|
|
+
|
|
.include "../Makefile.common"
|
|
|
|
SRCS = fuse_main.c \
|
|
@@ -22,7 +24,8 @@
|
|
|
|
.if defined(KERNCONF)
|
|
KERNCONF1!= echo ${KERNCONF} | sed -e 's/ .*//g'
|
|
-KERNCONFDIR= /usr/obj/usr/src/sys/${KERNCONF1}
|
|
+KRNLOBJDIR!= make -C /usr/src -f /usr/src/Makefile.inc1 -V KRNLOBJDIR
|
|
+KERNCONFDIR= ${KRNLOBJDIR}/${KERNCONF1}
|
|
.endif
|
|
|
|
.if defined(KERNCONFDIR)
|