freebsd-ports/net/grive2/files/patch-grive_CMakeLists.txt
Carlos J. Puga Medina 58195fe1bb - Unbreak build with Clang 6
- Rework patches to push the code upstream
- Fix WWW in pkg-descr
- Pet portlint

Reported by:	pkg-fallout
2018-01-16 00:42:00 +00:00

13 lines
644 B
Text

--- grive/CMakeLists.txt.orig 2016-01-14 20:51:31 UTC
+++ grive/CMakeLists.txt
@@ -26,4 +26,9 @@ set_target_properties( grive_executable
)
install(TARGETS grive_executable RUNTIME DESTINATION bin)
-install(FILES doc/grive.1 DESTINATION share/man/man1 )
+
+if ( ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD" OR ${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD" )
+ install(FILES doc/grive.1 DESTINATION man/man1 )
+else ( ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD" OR ${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD" )
+ install(FILES doc/grive.1 DESTINATION share/man/man1 )
+endif( ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD" OR ${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD" )