b562f2a6f6
so that Linux apps like Skype or Flash can talk to V4L2 devices (like webcams) via /dev/videoX. The patches this kld is based on have been committed to FreeBSD 9.0-current now (r221426) so this port is only needed on eaerlier versions. Note this port does not contain actual V4L2 drivers, those are provided by e.g. the multimedia/webcamd port. WWW: http://people.freebsd.org/~nox/dvb/
16 lines
283 B
Text
16 lines
283 B
Text
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1,11 +1,11 @@
|
|
# $FreeBSD$
|
|
|
|
-.if ${MACHINE_CPUARCH} == "amd64"
|
|
+.if ${MACHINE_ARCH} == "amd64"
|
|
SFX= 32
|
|
CFLAGS+=-DCOMPAT_FREEBSD32 -DCOMPAT_LINUX32
|
|
.endif
|
|
|
|
-KMOD= linux_v4l2
|
|
+KMOD= linux_v4l2wrapper
|
|
SRCS= linux_v4l2.c
|
|
|
|
.include <bsd.kmod.mk>
|