46 lines
1.2 KiB
Text
46 lines
1.2 KiB
Text
--- ../configure.orig Tue Nov 14 10:37:41 2006
|
|
+++ ../configure Mon Nov 27 22:52:52 2006
|
|
@@ -3466,16 +3466,21 @@
|
|
#define HAVE_SOCKLEN_T 1
|
|
EOF
|
|
|
|
- CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
|
|
+ cat >> confdefs.h <<\EOF
|
|
+#define HAVE_SOCKLEN_T 1
|
|
+EOF
|
|
+
|
|
+ CFLAFS="$CFLAGS $DSO_CFLAGS -ansi -Wall -pipe -DXP_UNIX"
|
|
MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
|
|
if test "$MOZ_OBJFORMAT" = "elf"; then
|
|
- DLL_SUFFIX=so
|
|
+ DLL_SUFFIX=so.1
|
|
else
|
|
DLL_SUFFIX=so.1.0
|
|
fi
|
|
MKSHLIB='$(CC) $(DSO_LDOPTS) -o $@'
|
|
DSO_CFLAGS=-fPIC
|
|
DSO_LDOPTS='-shared -Wl,-soname -Wl,$(notdir $@)'
|
|
+ DSO_LDOPTS="$DSO_LDOPTS $BSD_PTHREAD_LIBS"
|
|
MDCPUCFG_H=_freebsd.cfg
|
|
PR_MD_CSRCS=freebsd.c
|
|
;;
|
|
@@ -5467,11 +5472,6 @@
|
|
#define _THREAD_SAFE 1
|
|
EOF
|
|
|
|
- if test "$ac_cv_have_dash_pthread" = "yes"; then
|
|
- _PTHREAD_LDFLAGS="-pthread"
|
|
- else
|
|
- _PTHREAD_LDFLAGS="-lc_r"
|
|
- fi
|
|
;;
|
|
*-netbsd*)
|
|
if test "$ac_cv_have_dash_pthread" = "yes"; then
|
|
@@ -5864,6 +5864,7 @@
|
|
config/nsprincl.mk
|
|
config/nsprincl.sh
|
|
config/nspr-config
|
|
+config/nspr.pc
|
|
lib/Makefile
|
|
lib/ds/Makefile
|
|
lib/libc/Makefile
|