freebsd-ports/net/zmap/files/patch-CMakeLists.txt
Wen Heping 26a3f88b67 ZMap is a fast single packet network scanner designed for Internet-wide network
surveys. On a typical desktop computer with a gigabit Ethernet connection, ZMap
is capable scanning the entire public IPv4 address space in under 45 minutes.
With a 10gigE connection and PF_RING, ZMap can scan the IPv4 address space in
under 5 minutes.

WWW: https://zmap.io/

PR:		208925
Submitted by:	yuri@rawbw.com
2016-05-10 01:30:03 +00:00

15 lines
730 B
Text

--- CMakeLists.txt.orig 2016-04-20 05:20:38 UTC
+++ CMakeLists.txt
@@ -135,11 +135,7 @@ message(STATUS "Default ZMap configurati
foreach(EACH_CONF ${CONF_FILES})
get_filename_component(CONF_BASENAME ${EACH_CONF} NAME)
message(STATUS "Checking if ${CONF_BASENAME} exists there...")
- if(NOT EXISTS "/etc/zmap/${CONF_BASENAME}")
- install(FILES ${EACH_CONF} DESTINATION ${CONFIG_DESTINATION})
- else()
- message(WARNING "Existing configuration file detected at /etc/zmap/${CONF_BASENAME}, ${CONF_BASENAME} from sources will NOT be installed. Please check and install manually!")
- endif()
+ install(FILES ${EACH_CONF} DESTINATION ${CONFIG_DESTINATION})
endforeach()
# Allow Debian Packaging