5af2b1ef15
<snip> - Improved performance of the new L-EC code by up to a factor 2 depending on the hardware. - 'read-test' runs L-EC encoder over mode 1 or mode 2 form 1 sectors to allow performance testing in conjunction with option --speed. new: - toc2cddb: translates a TOC file into a cddb file. (Giuseppe Corbelli) new: - cue2toc: convert CUE to TOC format for audio CDs. (Matthias Czapla) <snip> Note: The 1.1.8 tarball was re-rolled twice because of missing files and a show-stopper in gcdmaster and some SourceForge mirrors still might need to catch up on it. If you have problems with differing checksums please fetch from ftp://us.dl.sourceforge.net/pub/sourceforge/cdrdao, which is known to carry the latest version. - Use/respect DATADIR and DOCSDIR. - Make PREFIX-clean by respecting PREFIX instead of LOCALBASE. - First part of splitting gcdmaster into a slave port because the conditional compilation via HAVE_GNOME caused problems when gnomelibs where installed afterwards (PR 61840). - Tidy the PORTDOCS a bit, e.g. no longer install the release notes for previous releases, they are easily accessible on the homepage anyway. - On deinstall, remind the user to delete the global config file if existent and permanently removing this port. - In pkg-descr, mention that cdrdao also handles the bin/cue format. Wording taken from the Debian cdrdao package. - Fix some references in the cdrdao manpage to fit FreeBSD. - Remove the WITH_PTHREADS knob, it was never very usefull on FreeBSD. - Remove the WITHOUT_SCGLIB knob, the "native" CAM interface of cdrdao has issues with ATAPICAM and probably will be removed in future version. - Remove "-DBSD_SCSI_SENSE_BUG" from CFLAGS, for an explanation see sysutils/sformat/Makefile revision 1.5. Submitted by: maintainer
15 lines
480 B
C++
15 lines
480 B
C++
--- dao/main.cc.orig Sat Dec 28 03:01:20 2002
|
|
+++ dao/main.cc Sat Dec 28 03:04:38 2002
|
|
@@ -1890,11 +1890,7 @@
|
|
|
|
SETTINGS = new Settings;
|
|
|
|
- settingsPath = "/etc/cdrdao.conf";
|
|
- if (SETTINGS->read(settingsPath) == 0)
|
|
- message(3, "Read settings from \"%s\".", settingsPath);
|
|
-
|
|
- settingsPath = "/etc/defaults/cdrdao";
|
|
+ settingsPath = "%%PREFIX%%/etc/cdrdao.conf";
|
|
if (SETTINGS->read(settingsPath) == 0)
|
|
message(3, "Read settings from \"%s\".", settingsPath);
|
|
|