52 lines
2 KiB
Text
52 lines
2 KiB
Text
--- configure.in.orig 2014-02-17 23:37:01.241643774 +0000
|
|
+++ configure.in 2014-02-17 23:38:03.349639470 +0000
|
|
@@ -1386,11 +1386,11 @@
|
|
AC_CHECK_DECLS([sys_nerr], [], [], [$ac_includes_default
|
|
@%:@include <errno.h>])
|
|
|
|
-AC_CHECK_LIB(crypt, crypt)
|
|
-AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
|
|
-AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
|
|
-AC_CHECK_LIB(socket, socketpair) # SunOS/Solaris
|
|
-AC_CHECK_LIB(rt, clock_gettime) # GNU/Linux
|
|
+AC_SEARCH_LIBS(crypt, crypt)
|
|
+AC_SEARCH_LIBS(dlopen, dl) # Dynamic linking for SunOS/Solaris and SYSV
|
|
+AC_SEARCH_LIBS(shl_load, dld) # Dynamic linking for HP-UX
|
|
+AC_SEARCH_LIBS(socketpair, socket) # SunOS/Solaris
|
|
+AC_SEARCH_LIBS(clock_gettime, rt) # GNU/Linux
|
|
|
|
AS_CASE(["$target_cpu"],
|
|
[alpha*|sh4|sh4el|sh4eb], [AS_CASE(["$target_os"::"$GCC"],
|
|
@@ -2081,7 +2081,7 @@
|
|
fi
|
|
|
|
if test x"$enable_pthread" = xyes; then
|
|
- for pthread_lib in thr pthread pthreads c c_r root; do
|
|
+ for pthread_lib in pthread thr pthreads c c_r root; do
|
|
AC_CHECK_LIB($pthread_lib, pthread_kill,
|
|
rb_with_pthread=yes, rb_with_pthread=no)
|
|
if test "$rb_with_pthread" = "yes"; then break; fi
|
|
@@ -2089,6 +2089,7 @@
|
|
if test x"$rb_with_pthread" = xyes; then
|
|
AC_DEFINE(_REENTRANT)
|
|
AC_DEFINE(_THREAD_SAFE)
|
|
+ [pthread], [MAINLIBS="-pthread $MAINLIBS"],
|
|
AC_DEFINE(HAVE_LIBPTHREAD)
|
|
AC_CHECK_HEADERS(pthread_np.h, [], [], [@%:@include <pthread.h>])
|
|
AS_CASE([$pthread_lib],
|
|
@@ -2326,7 +2327,6 @@
|
|
: ${LDSHARED='$(CC) -shared'}
|
|
if test "$rb_cv_binary_elf" = yes; then
|
|
LDFLAGS="$LDFLAGS -rdynamic"
|
|
- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
|
|
else
|
|
test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
|
|
fi
|
|
@@ -2713,6 +2713,7 @@
|
|
[freebsd*|dragonfly*], [
|
|
SOLIBS='$(LIBS)'
|
|
LIBRUBY_SO='lib$(RUBY_SO_NAME).so.$(MAJOR)$(MINOR)'
|
|
+ LIBRUBY_DLDFLAGS='-Wl,-soname,$(LIBRUBY_SO)'
|
|
if test "$rb_cv_binary_elf" != "yes" ; then
|
|
LIBRUBY_SO="$LIBRUBY_SO.\$(TEENY)"
|
|
LIBRUBY_ALIASES=''
|