freebsd-ports/devel/msp430-gcc/files/patch-libgcc-Makefile.in
Lev A. Serebryakov 3610257e24 Update to brand-new LTS (Long Terms Support) release.
gcc is 4.6.3
  binutils is 2.21.1a

Feature safe: yes
2012-04-08 15:35:52 +00:00

26 lines
915 B
Text

--- libgcc/Makefile.in.orig 2011-01-26 07:19:58.000000000 +0300
+++ libgcc/Makefile.in 2012-04-08 17:22:26.000000000 +0400
@@ -878,6 +878,7 @@
$(INSTALL_DATA) $$file $(gcc_objdir)$(MULTISUBDIR)/; \
case $$file in \
*.a) \
+ chmod 644 $(gcc_objdir)$(MULTISUBDIR)/$$file ; \
$(RANLIB) $(gcc_objdir)$(MULTISUBDIR)/$$file ;; \
esac; \
done
@@ -915,6 +916,7 @@
$(INSTALL_DATA) $$file $(gcc_objdir)$(MULTISUBDIR)/; \
case $$file in \
*.a) \
+ chmod 644 $(gcc_objdir)$(MULTISUBDIR)/$$file ; \
$(RANLIB) $(gcc_objdir)$(MULTISUBDIR)/$$file ;; \
esac; \
done
@@ -974,6 +976,7 @@
$(INSTALL_DATA) $$file $(DESTDIR)$(inst_libdir)/; \
case $$file in \
*.a) \
+ chmod 644 $(gcc_objdir)$(MULTISUBDIR)/$$file ; \
$(RANLIB) $(gcc_objdir)$(MULTISUBDIR)/$$file ;; \
esac; \
done