freebsd-ports/games/unnethack/files/patch-makefile.top
Greg Lewis e9b36c2745 . Use ${DATADIR} consistently instead fo sometimes using
${PREFIX}/share/slashem

Submitted by:	sat@ (although this is a slightly different implementation)
2007-08-25 18:09:49 +00:00

56 lines
1.6 KiB
Text

$FreeBSD$
--- sys/unix/Makefile.top.orig Sat Dec 30 05:08:31 2006
+++ sys/unix/Makefile.top Sun Aug 19 01:18:58 2007
@@ -14,20 +14,19 @@
# MAKE = make
# make NetHack
-PREFIX = /usr
GAME = slashem
# GAME = slashem.prg
GAMEUID = games
-GAMEGRP = bin
+GAMEGRP = games
# Permissions - some places use setgid instead of setuid, for instance
# See also the option "SECURE" in include/config.h
GAMEPERM = 04755
-FILEPERM = 0644
+FILEPERM = 0664
EXEPERM = 0755
DIRPERM = 0755
-VARFILEPERM = 0644
-VARDIRPERM = 0755
+VARFILEPERM = 0664
+VARDIRPERM = 0775
# GAMEDIR also appears in config.h as "HACKDIR".
# VARDIR may also appear in unixconf.h as "VAR_PLAYGROUND" else GAMEDIR
@@ -40,7 +39,7 @@
# These must agree with the definitions in unixconf.h
# Defs. for non file areas support.
-GAMEDIR = $(PREFIX)/local/slashemdir
+GAMEDIR = $(DATADIR)
VARDIR = $(GAMEDIR)
FILE_AREA_VAR = $(VARDIR)
FILE_AREA_SAVE = $(VARDIR)/save
@@ -49,7 +48,7 @@
FILE_AREA_DOC = $(GAMEDIR)
FILE_AREA_BONES = $(FILE_AREA_VAR)
FILE_AREA_LEVL = $(FILE_AREA_VAR)
-SHELLDIR = $(PREFIX)/local/bin
+SHELLDIR = $(PREFIX)/bin
# Defs. compatible with Linux's FSSTND 1.2
# FILE_AREA_VAR = /var/lib/games/slashem
@@ -290,7 +289,7 @@
$(MAKE) dofiles-$${target-nodlb}
cp src/$(GAME) $(FILE_AREA_UNSHARE)
cp util/recover $(FILE_AREA_UNSHARE)
- cp dat/license doc/Guidebook.txt $(FILE_AREA_DOC)
+ cp dat/license $(FILE_AREA_DOC)
# cp win/Qt/KDE/kslashem.kdelnk $(KDEDIR)/share/applnk/Games
-rm -f $(SHELLDIR)/$(GAME)
sed -e 's;/usr/games/lib/nethackdir;$(FILE_AREA_UNSHARE);' \