"Aliens versus predator" game, demo from Alien. WWW: http://www.icculus.org/avp/ PR: ports/138806 Submitted by: Stas Timokhin [devel stasyan.com] (the email address in the PR is defunct) Fixes from: Anonymous [swell.k gmail.com], myself
30 lines
2.1 KiB
Text
30 lines
2.1 KiB
Text
--- avp_git/Makefile.orig
|
|
+++ avp_git/Makefile
|
|
@@ -1,15 +1,8 @@
|
|
-CC = gcc
|
|
-CXX = g++
|
|
-
|
|
-CFLAGS = -m32 -g -Wall -pipe
|
|
-#CFLAGS += -O2
|
|
-#CFLAGS += -DNDEBUG -O6 -ffast-math -fomit-frame-pointer -march=pentium3 -mtune=pentium4
|
|
-
|
|
CFLAGS += -Isrc -Isrc/include -Isrc/win95 -Isrc/avp -Isrc/avp/win95 -Isrc/avp/support -Isrc/avp/win95/frontend -Isrc/avp/win95/gadgets
|
|
-CFLAGS += $(shell sdl-config --cflags) $(shell openal-config --cflags)
|
|
+CFLAGS += $(shell sdl-config --cflags) $(shell pkg-config openal --cflags)
|
|
-CXXFLAGS = $(CFLAGS)
|
|
+CXXFLAGS += $(CFLAGS)
|
|
|
|
-LDLIBS = -m32 $(shell sdl-config --libs) $(shell openal-config --libs)
|
|
+LDLIBS = $(shell sdl-config --libs) $(shell pkg-config openal --libs)
|
|
|
|
ROOT = main.c files.c winapi.c stubs.c version.c mathline.c opengl.c fmv.c oglfunc.c openal.c cdplayer.c menus.c net.c frustum.c kshape.c map.c maths.c md5.c mem3dc.c mem3dcpp.cpp module.c morph.c object.c shpanim.c sphere.c tables.c vdb.c
|
|
AVP = ai_sight.c avpview.c bh_agun.c bh_ais.c bh_alien.c bh_binsw.c bh_cable.c bh_corpse.c bh_deathvol.c bh_debri.c bh_dummy.c bh_fan.c bh_far.c bh_fhug.c bh_gener.c bh_ldoor.c bh_lift.c bh_light.c bh_lnksw.c bh_ltfx.c bh_marin.c bh_mission.c bh_near.c bh_pargen.c bh_plachier.c bh_plift.c bh_pred.c bh_queen.c bh_rubberduck.c bh_selfdest.c bh_snds.c bh_spcl.c bh_swdor.c bh_track.c bh_types.c bh_videoscreen.c bh_waypt.c bh_weap.c bh_xeno.c bonusabilities.c cconvars.cpp cdtrackselection.cpp cheatmodes.c comp_map.c comp_shp.c consolelog.cpp davehook.cpp deaths.c decal.c detaillevels.c dynamics.c dynblock.c equipmnt.c extents.c game.c game_statistics.c gamecmds.cpp gamevars.cpp hmodel.c hud.c inventry.c language.c lighting.c load_shp.c los.c mempool.c messagehistory.c missions.cpp movement.c paintball.c particle.c pfarlocs.c pheromon.c player.c pmove.c psnd.c psndproj.c pvisible.c savegame.c scream.cpp secstats.c sfx.c stratdef.c targeting.c track.c triggers.c weapons.c
|
|
@@ -48,7 +41,7 @@ OBJ = $(ROOTOBJ) $(AVPOBJ) $(SHAPESOBJ)
|
|
all: avp
|
|
|
|
avp: $(OBJ)
|
|
- $(CXX) -o avp $(OBJ) $(LDLIBS)
|
|
+ $(CXX) -o avp $(OBJ) $(LDLIBS) $(LDFLAGS)
|
|
|
|
clean:
|
|
-rm -rf $(OBJ) avp
|