freebsd-ports/lang/gcc/files/patch-al

26 lines
801 B
Text

--- gcc/configure.in.orig Sun Oct 1 23:50:51 2000
+++ gcc/configure.in Mon Oct 9 18:56:34 2000
@@ -786,6 +786,23 @@
if test x$enable_threads = xyes; then
thread_file='posix'
fi
+ alpha*-*-freebsd*)
+ tm_file="${tm_file} freebsd.h alpha/elf.h alpha/freebsd.h"
+ xm_file="${xm_file} xm-freebsd.h"
+ target_cpu_default="MASK_GAS"
+ tmake_file="t-freebsd alpha/t-crtbe alpha/t-alpha alpha/t-ieee"
+ extra_parts="crtbegin.o crtend.o crtbeginS.o crtendS.o"
+ xmake_file=none
+ fixincludes=fixinc.wrap
+ gas=yes gnu_ld=yes
+ stabs=yes
+ case x${enable_threads} in
+ xyes | xpthreads | xposix)
+ thread_file='posix'
+ tmake_file="${tmake_file} t-freebsd-thread"
+ ;;
+ esac
+ ;;
;;
alpha*-*-netbsd*)
tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"