dde08c696b
are savepoints (within transactions), point-in-time recovery and tablespaces. Check out the release notes and the shiny new PostgreSQL.org website at: http://www.PostgreSQL.org/docs/8.0/static/release.html#RELEASE-8-0 The port uses the new postgresql ports' layout and is split into a server and a client part. The following knobs can be used by ports depending on PostgreSQL: # USE_PGSQL - Add PostgreSQL client dependency. # If no version is given (by the maintainer via the port or # by the user via defined variable), try to find the # currently installed version. Fall back to default if # necessary (PostgreSQL-7.4 = 74). # DEFAULT_PGSQL_VER # - PostgreSQL default version. Can be overridden within a port. # Default: 74. # WANT_PGSQL_VER # - Maintainer can set an arbitrary version of PostgreSQL by # using it. # BROKEN_WITH_PGSQL # - This variable can be defined if the ports doesn't support # one or more versions of PostgreSQL. PR: 75344 Approved by: portmgr@ (kris), ade & sean (mentors)
17 lines
356 B
Text
17 lines
356 B
Text
--- src/makefiles/Makefile.freebsd.orig Fri Nov 19 01:41:39 2004
|
|
+++ src/makefiles/Makefile.freebsd Tue Dec 21 02:44:09 2004
|
|
@@ -11,7 +11,7 @@
|
|
ifeq ($(findstring sparc,$(host_cpu)), sparc)
|
|
CFLAGS_SL = -fPIC -DPIC
|
|
else
|
|
-CFLAGS_SL = -fpic -DPIC
|
|
+CFLAGS_SL = -fPIC -DPIC
|
|
endif
|
|
|
|
|
|
@@ -29,3 +29,5 @@
|
|
endif
|
|
|
|
sqlmansect = 7
|
|
+
|
|
+allow_nonpic_in_shlib = yes
|