freebsd-ports/net/pacemaker1/files/extra-patch-cts_watcher.py
Vinícius Zavam 8e9f86e4ce net/pacemaker1: base ncurses, py37- support, and un-deprecate it
Makefiles
    - un-deprecate the port; bump PORTREVISION;
    - apply certain patches only if PYTHON_SUFFIX > 36;
    - use base system's ncurses instead of ports';

  pkg-plist: use %%PYTHON_SUFFIX%%, instead of its value

  files/*
    - extra*.py: https://docs.python.org/3/whatsnew/3.7.html
    - patch-tools_cibsecret.in: make proper use of `md5`

PR:		243944
Submitted by:	swills
2020-02-07 17:23:49 +00:00

13 lines
413 B
Python

--- cts/watcher.py.orig 2020-02-07 14:06:26 UTC
+++ cts/watcher.py
@@ -140,8 +140,8 @@ class SearchObj:
self.logger.debug(message)
def harvest(self, delegate=None):
- async = self.harvest_async(delegate)
- async.join()
+ async_calls = self.harvest_async(delegate)
+ async_calls.join()
def harvest_async(self, delegate=None):
self.log("Not implemented")