27470e1676
* print/ghostscript{7,8,9,9-agpl}-base Installs Ghostscript binary, libgs, and related files. These ports do not depend on X11 libraries (i.e. x11* devices are not available). USES=ghostscript will set dependency on one of them depending on GHOSTSCRIPT_DEFAULT. The default device is set to "display" or "bbox". * print/ghostscript{7,8,9,9-agpl}-x11 Installs a shared library which provides X11 support to the installed Ghostscript binaries. x11* devices will be enabled when the library is available. This depends on *-base (RUN_DEPENDS). USES=ghostscript:x11 will set dependency on one of them. - Fix integer overflow reported as CVE-2015-3228. - Update Uses/ghostscript.mk: * Add x11 keyword. nox11 keyword is now obsolete. * Use packagename in *_DEPENDS line to prevent relationship between -base and -x11 packages from being broken. - Fix x11/nox11 keyword and bump PORTREVISION in ports using USES=ghostscript to update dependency of pre-compiled packages.
44 lines
1.1 KiB
C
44 lines
1.1 KiB
C
--- contrib/japanese/gdevdmpr.c.orig Thu Apr 26 01:27:24 2007
|
|
+++ contrib/japanese/gdevdmpr.c Tue May 15 01:44:09 2007
|
|
@@ -41,8 +41,6 @@
|
|
/* include library header. */
|
|
#include "dviprlib.h"
|
|
|
|
-extern FILE *lib_fopen(const char *);
|
|
-
|
|
#define LOCAL_DEBUG 0
|
|
|
|
#define DEVICE_NAME "dmprt"
|
|
@@ -405,8 +403,6 @@
|
|
if (pddev->dmprt.max_height>0 && pddev->dmprt.max_height<pddev->height)
|
|
pddev->height = pddev->dmprt.max_height;
|
|
|
|
- dviprt_setmessagestream(pddev->dmprt.debug_f ? stderr : NULL);
|
|
-
|
|
return code;
|
|
}
|
|
|
|
@@ -425,8 +421,6 @@
|
|
if (code < 0) return code;
|
|
if (code == 0) pddev->dmprt.debug_f = vbool;
|
|
|
|
- dviprt_setmessagestream(pddev->dmprt.debug_f ? stderr : NULL);
|
|
-
|
|
code = param_read_bool(plist, "Verbose", &vbool);
|
|
if (code < 0) return code;
|
|
pddev->dmprt.verbose_f = vbool;
|
|
@@ -841,13 +835,12 @@
|
|
char *env;
|
|
|
|
strcpy(fname,fnamebase);
|
|
- fp = lib_fopen(fname);
|
|
+ fp = fopen(fname,"r");
|
|
if (fp == NULL) {
|
|
env = getenv("TEXCFG");
|
|
if (env) {
|
|
strcpy(fname,env);
|
|
strcat(fname, gp_file_name_concat_string(env,strlen(env)));
|
|
- strcat(fname,fnamebase);
|
|
fp = fopen(fname,gp_fmode_rb);
|
|
}
|
|
}
|