Among changes: - Switch KDE4_PREFIX to ${LOCALBASE} - Remove now needless misc/kde4-shared-mime-info port - Add stage support - Remove ancient CONFLICTS (KDE 4.9 and less) and LATEST_LINK - Squeeze MASTER_SITES/MASTER_SITE_SUBDIR - Convert LIB_DEPENDS to new style - Use options helpers - Drop support for FreeBSD 7.x - Remove Qt/KDE 3 related workarounds - Remove local patches and use upstream version scheme for libraries - sysutils/kdeadmin4, net/kdenetwork4, devel/kdesdk4, and x11-clocks/kdetoys4 ports have been split. - devel/kcachegrind is now a part of KDE SC [1] - more logs in area51 repo... New ports: devel/kde-dev-scripts: KDE development scripts devel/kde-dev-utils: KDE development utilities games/klickety: Tetris themed solitaire games/picmi: Single player logic-based puzzle game textproc/libkomparediff2: Library to compare files and strings The area51 repository features commits by Schaich Alonso, avilla, rakuco and myself. PR: ports/186491 Exp-run: by bdrewery Approved by: beat (former maintainer) [1]
29 lines
1.2 KiB
Text
29 lines
1.2 KiB
Text
--- CMakeLists.txt.orig 2013-08-14 12:32:08.088461763 +0000
|
|
+++ CMakeLists.txt 2013-08-14 12:33:12.856460461 +0000
|
|
@@ -36,17 +36,21 @@
|
|
endif (DEPEND_PACKAGE_Marble)
|
|
macro_log_feature(MARBLE_FOUND "Marble" "Desktop Globe" "http://marble.kde.org" FALSE "" "RECOMMENDED: Marble is used to provide a desktop globe wallpaper for Plasma.")
|
|
|
|
-if (NEPOMUK_FOUND)
|
|
- include_directories( ${SOPRANO_INCLUDE_DIR} ${NEPOMUK_INCLUDE_DIR} )
|
|
-endif (NEPOMUK_FOUND)
|
|
-
|
|
add_definitions (${QT_DEFINITIONS} ${KDE4_DEFINITIONS})
|
|
add_definitions(-DQT_USE_FAST_CONCATENATION -DQT_USE_FAST_OPERATOR_PLUS)
|
|
-include_directories (${KDE4_INCLUDES}
|
|
+include_directories (${QT_QTGUI_INCLUDE_DIR}
|
|
+ ${QT_QTCORE_INCLUDE_DIR}
|
|
+ ${QT_QTXML_INCLUDE_DIR}
|
|
+ ${PHONON_INCLUDE_DIR}
|
|
+ ${KDE4_INCLUDES}
|
|
${KDE4WORKSPACE_INCLUDE_DIR}
|
|
${KDEPIMLIBS_INCLUDE_DIR}
|
|
${CMAKE_CURRENT_SOURCE_DIR}/libs)
|
|
|
|
+if (NEPOMUK_FOUND)
|
|
+ include_directories( ${SOPRANO_INCLUDE_DIR} ${NEPOMUK_INCLUDE_DIR} )
|
|
+endif (NEPOMUK_FOUND)
|
|
+
|
|
add_subdirectory(libs)
|
|
add_subdirectory(applets)
|
|
add_subdirectory(dataengines)
|