freebsd-ports/net/asterisk14/files/patch-astman::Makefile
2004-10-17 18:00:02 +00:00

25 lines
715 B
Text

$FreeBSD$
--- astman/Makefile.orig Sat Jun 26 22:25:39 2004
+++ astman/Makefile Thu Oct 14 19:14:22 2004
@@ -5,16 +5,16 @@
OSARCH=$(shell uname -s)
ifeq ($(findstring BSD,${OSARCH}),BSD)
-CFLAGS+=-I/usr/local/include -L/usr/local/lib
+CFLAGS+=-I$(LOCALBASE)/include -L$(LOCALBASE)/lib
endif
-TARGET=$(shell if [ -f /usr/include/newt.h ]; then echo "astman"; else if [ -f /usr/local/include/newt.h ]; then echo "astman"; else echo "none" ; fi ; fi)
+TARGET=astman
all: depend $(TARGET)
install:
if [ "$(TARGET)" != "none" ]; then \
for x in $(TARGET); do \
- install -m 755 $$x $(DESTDIR)$(ASTSBINDIR)/astman; \
+ $(BSD_INSTALL_PROGRAM) $$x $(DESTDIR)$(ASTSBINDIR)/astman; \
done ; \
fi