37 lines
1.5 KiB
Text
37 lines
1.5 KiB
Text
--- CMakeLists.txt.orig 2010-04-10 03:37:25.000000000 +0400
|
|
+++ CMakeLists.txt 2010-04-15 19:08:24.000000000 +0400
|
|
@@ -92,7 +92,6 @@
|
|
# Did we find wxWidgets ? This condition will fail for as long as the internal Vars do not point to the proper wxWidgets Configuration.
|
|
IF(wxWidgets_FOUND)
|
|
# Include wxWidgets macros
|
|
- INCLUDE(${wxWidgets_USE_FILE})
|
|
IF(MSVC)
|
|
INCLUDE_DIRECTORIES( ${wxWidgets_ROOT_DIR}/include/msvc )
|
|
ENDIF(MSVC)
|
|
@@ -100,6 +99,9 @@
|
|
SET(wxWidgets_RC_DIR ${wxWidgets_ROOT_DIR}/include)
|
|
ENDIF(MINGW)
|
|
INCLUDE_DIRECTORIES( ${wxWidgets_INCLUDE_DIRS} )
|
|
+ STRING(REGEX REPLACE ";" ";-D" wxWidgets_DEFINITIONS "${wxWidgets_DEFINITIONS}")
|
|
+ SET(wxWidgets_DEFINITIONS "-D${wxWidgets_DEFINITIONS}")
|
|
+ ADD_DEFINITIONS( ${wxWidgets_DEFINITIONS} )
|
|
ELSE(wxWidgets_FOUND)
|
|
# For Convenience. If we cannot continue, inform the User.
|
|
MESSAGE( FATAL_ERROR "wxWidgets library not found! Please install the package to continue")
|
|
@@ -120,7 +122,7 @@
|
|
|
|
Add_Subdirectory( ${springlobby_SOURCE_DIR}/src/sound/alure )
|
|
INCLUDE_DIRECTORIES( ${springlobby_SOURCE_DIR}/src/sound/alure/include )
|
|
- LINK_LIBRARIES( ${OPENAL_LIBRARY} ${springlobby_BINARY_DIR}/src/sound/alure/libalure.a )
|
|
+ LINK_LIBRARIES( ${OPENAL_LIBRARY} alure )
|
|
ELSE ( OPTION_SOUND )
|
|
# Disable sound.
|
|
ADD_DEFINITIONS( -DDISABLE_SOUND )
|
|
@@ -174,6 +176,7 @@
|
|
LIST( APPEND SLSharedWithSettings ${curlSRC} )
|
|
ELSE( OPTION_TORRENT_SYSTEM )
|
|
ADD_DEFINITIONS( -DNO_TORRENT_SYSTEM )
|
|
+ LIST( APPEND SLSharedWithSettings ${curlSRC} )
|
|
ENDIF( OPTION_TORRENT_SYSTEM )
|
|
|
|
|