6f5f9f287c
PR: 221509 Submitted by: myself Approved by: adamw (mentor) Differential Revision: https://reviews.freebsd.org/D12890
24 lines
616 B
Text
24 lines
616 B
Text
--- architecture/osclib/oscpack/Makefile.orig 2017-06-07 15:07:18 UTC
|
|
+++ architecture/osclib/oscpack/Makefile
|
|
@@ -14,6 +14,13 @@ ARCHFLAGS :=
|
|
CXXFLAGS += -fPIC
|
|
|
|
else
|
|
+ifeq ($(system), FreeBSD)
|
|
+subprojects := ip ip/posix osc
|
|
+sources := $(sort $(wildcard ip/*.cpp) $(wildcard ip/posix/*.cpp) $(wildcard osc/*.cpp))
|
|
+ARCHFLAGS :=
|
|
+CXXFLAGS += -fPIC
|
|
+
|
|
+else
|
|
ifeq ($(system), GNU/kFreeBSD)
|
|
subprojects := ip ip/posix osc
|
|
sources := $(sort $(wildcard ip/*.cpp) $(wildcard ip/posix/*.cpp) $(wildcard osc/*.cpp))
|
|
@@ -26,6 +33,7 @@ ARCHFLAGS :=
|
|
endif
|
|
endif
|
|
endif
|
|
+endif
|
|
|
|
VPATH = $(subprojects)
|
|
|