f6862ef651
Unfortunately, LibreOffice project completely dropped support for pre-C++11 compilers and libraries since 4.4. Therefore, we cannot easily build it on FeeBSD 9.x any more unless the system was rebuilt with WITH_CLANG_IS_CC and WITH_LIBCPLUSPLUS. If user is unable to upgrade the system for some reason, the old port, i.e., 4.3.7, is still available from devel/libreoffice4 (with no language packs).
14 lines
407 B
Makefile
14 lines
407 B
Makefile
--- chart2/Library_chartopengl.mk.orig 2015-08-22 06:41:35 UTC
|
|
+++ chart2/Library_chartopengl.mk
|
|
@@ -66,6 +66,11 @@ else ifeq ($(OS),MACOSX)
|
|
$(eval $(call gb_Library_use_system_darwin_frameworks,chartopengl,\
|
|
OpenGL \
|
|
))
|
|
+else ifeq ($(OS),FREEBSD)
|
|
+$(eval $(call gb_Library_add_libs,chartopengl,\
|
|
+ -lGL \
|
|
+ -lX11 \
|
|
+))
|
|
else ifeq ($(OS),LINUX)
|
|
$(eval $(call gb_Library_add_libs,chartopengl,\
|
|
-ldl \
|