26 lines
952 B
Text
26 lines
952 B
Text
--- Makefile.am.orig 2008-12-03 04:04:51.000000000 +0900
|
|
+++ Makefile.am 2011-03-19 05:18:20.000000000 +0900
|
|
@@ -32,6 +32,14 @@
|
|
python_PYTHON = \
|
|
pokereval.py
|
|
|
|
+if PYTHON_2_7
|
|
+py2_7exec_LTLIBRARIES = _pokereval_2_7.la
|
|
+_pokereval_2_7_la_SOURCES = pypokereval.c
|
|
+_pokereval_2_7_la_LDFLAGS = -module -no-undefined -version-info 1:0:0
|
|
+_pokereval_2_7_la_LIBADD = ${PYTHON2_7_LIBS} ${POKER_EVAL_LIBS}
|
|
+_pokereval_2_7_la_CFLAGS = ${PYTHON2_7_CFLAGS} ${POKER_EVAL_CFLAGS} -DPYTHON_VERSION=\"2_7\" -D'VERSION_NAME(w)=w\#\#2_7'
|
|
+endif
|
|
+
|
|
if PYTHON_2_6
|
|
py2_6exec_LTLIBRARIES = _pokereval_2_6.la
|
|
_pokereval_2_6_la_SOURCES = pypokereval.c
|
|
@@ -64,7 +72,7 @@
|
|
_pokereval_2_3_la_CFLAGS = ${PYTHON2_3_CFLAGS} ${POKER_EVAL_CFLAGS} -DPYTHON_VERSION=\"2_3\" -D'VERSION_NAME(w)=w\#\#2_3'
|
|
endif
|
|
|
|
-pkgconfigdir = ${libdir}/pkgconfig
|
|
+pkgconfigdir = $(prefix)/libdata/pkgconfig
|
|
pkgconfig_DATA = pypoker-eval.pc
|
|
|
|
EXTRA_DIST = config/python.m4 config/ccpython.m4 \
|