Calculations are done on expr, if given. Otherwise, the standard input is used. Numbers can be entered in hexadecimal (0xbeef), decimal (1984), octal (007), and binary (0b1001). All numerical operators (+, -, *, /, %), bit operators (|, ^, &, ~, <<, >>), and logical operators (==, !=, <, >, <=, >=, !, &&, ||) are supported. WWW: http://cyth.net/~ray/moo/ PR: ports/111824 Submitted by: Steven Kreuzer <skreuzer at f2o.org>
18 lines
463 B
Text
18 lines
463 B
Text
--- Makefile.orig Thu Apr 5 14:13:26 2007
|
|
+++ Makefile Thu Apr 5 14:14:06 2007
|
|
@@ -3,14 +3,11 @@
|
|
PROG= moo
|
|
SRCS= moo.c scan.c
|
|
CPPFLAGS+= -I${.CURDIR}
|
|
-COPTS+= -Wall -W -Wno-unused -Wshadow -pedantic
|
|
+COPTS+= -Wall -W -Wno-unused -Wshadow
|
|
CLEANFILES+= moo.c y.tab.h scan.c lex.yy.c
|
|
|
|
LOCALBASE?=/usr/local
|
|
BINDIR=${LOCALBASE}/bin
|
|
MANDIR=${LOCALBASE}/man/cat
|
|
-
|
|
-regress::
|
|
- cd ${.CURDIR}/regress && ${MAKE} MOO=${.OBJDIR}/moo
|
|
|
|
.include <bsd.prog.mk>
|