freebsd-ports/comms/gammu/files/extra-patch-contrib_CMakeLists.txt
Boris Samorodov 9b494490e7 Create an OPTION to install a bash completion script (off by default).
Do not install the script when this option is disabled. I.e. even
if bash is installed one should define the option "on" (or define
the environment option WITH_BASH) to install the script.

PR:		ports/158840 (based on)
Submitted by:	Ruslan Mahmatkhanov <cvs-src@yandex.ru>
2011-07-30 19:27:29 +00:00

11 lines
515 B
Text

--- contrib/CMakeLists.txt.orig 2011-07-30 22:17:01.433135057 +0400
+++ contrib/CMakeLists.txt 2011-07-30 22:17:27.233149981 +0400
@@ -10,7 +10,7 @@
option(INSTALL_PHP_EXAMPLES "Install PHP example scripts" ON)
if (BASH_BIN)
- option(INSTALL_BASH_COMPLETION "Install bash completion script for Gammu" ON)
+ option(INSTALL_BASH_COMPLETION "Install bash completion script for Gammu" OFF)
else (BASH_BIN)
option(INSTALL_BASH_COMPLETION "Install bash completion script for Gammu" OFF)
endif (BASH_BIN)