freebsd-ports/devel/loki/files/patch-test_SingletonDll_Makefile
Wen Heping 4b012c89ee - Update to 0.1.7
Added file(s):
- files/patch-Makefile.common
- files/patch-test_SingletonDll_Makefile

Removed file(s):
- files/patch-Makefile
- files/patch-include-loki-Threads.h
- files/patch-test-Makefile
- files/patch-test-SingletonDll-Makefile
- files/patch-test-SmartPtr-main.cpp

PR:		ports/144062
Submitted by:	"Charlie &" <snnn119@gmail.com> (maintainer)
Feature safe:	yes
2010-03-03 12:05:05 +00:00

25 lines
483 B
Text

$FreeBSD$
--- test/SingletonDll/Makefile.orig
+++ test/SingletonDll/Makefile
@@ -5,6 +5,11 @@
LIB2 := libsingletondll.dylib
SHARED_LIB_FLAG := -dynamiclib -fPIC
else
+ifeq ($(OS),FreeBSD)
+ LIB1 := libfoo.so
+ LIB2 := libsingletondll.so
+ SHARED_LIB_FLAG := --shared -fPIC
+else
ifeq ($(OS),Linux)
LIB1 := libfoo.so
LIB2 := libsingletondll.so
@@ -15,6 +20,7 @@
SHARED_LIB_FLAG := --shared
endif
endif
+endif
BIN1 := client$(BIN_SUFFIX)
SRC1 := client.cpp