freebsd-ports/sysutils/tss/files/patch-Makefile
Alejandro Pulver cc9194b4df Terminal ScreenSaver (or tss for short) is an attempt to clone and enhance
FreeBSD's text-mode screen saver. Although intended for GNU/Linux, it works
fine under FreeBSD and probably a lot of other Unix-based operating systems.
Unlike the daemonsaver in FreeBSD, you may choose ASCII art of your own liking
or make your own.

WWW: http://www.pulia.nu/tss/

PR:		ports/104773
Submitted by:	Peter Ankerstal <peter at pean.org>
2006-11-01 22:16:01 +00:00

22 lines
536 B
Text

--- ./Makefile.orig Fri Sep 22 04:48:22 2006
+++ ./Makefile Wed Nov 1 19:01:16 2006
@@ -2,14 +2,15 @@
EXECUTABLE = tss
SRC = src/main.c
-CFLAGS = -Wall -ansi -pedantic -lcurses -lcrypt -s #-DBSD
-COMPILE= $(CC) $(CFLAGS)
-CC = gcc
+CFLAGS += -Wall -ansi -pedantic -s -DBSD $(CPPFLAGS)
+LDFLAGS += -lcurses -lcrypt
+COMPILE = $(CC) $(CFLAGS)
+CC ?= gcc
all: $(EXECUTABLE)
$(EXECUTABLE): $(SRC)
- $(CC) $(CFLAGS) -o $(EXECUTABLE) $(SRC)
+ $(CC) $(CFLAGS) -o $(EXECUTABLE) $(SRC) $(LDFLAGS)
%.o: %.c
$(COMPILE) -o $@ $<