freebsd-ports/x11/kdelibs4/files/patch-cmake_modules_FindLibKonq.cmake
Max Brazhnikov 1f8475f22f Mk/bsd.kde4.mk:
- rework KDE4_BUILDENV

All ports:
- remove needless post-extract target
- make patches relative to ${PATCH_WRKSRC}
- clean up
- bump PORTREVISION when required

databases/akonadi:
- replace dependency on boost-python-libs with boost-libs
  (finally, boost-pyhton does not conflict with boost \o/)

deskutils/kdepim*:
- replace boost-python-libs with boost-libs
- reduce dependencies
- respect PREFIX
- fix build with qt3 installed

misc/kdeedu4:
- add dependency on astro/xplanet (for KStars)

misc/kdeutils4:
- add dependency on devel/qca (for okteta)
- make dependency on kdebase non-optional

multimedia/kdemultimedia4:
- add optional support for PulseAudio

x11/kdebase4:
- remove needless dependency on kdebase4-runtime

x11/kdebase4-runtime, x11/kdebase4-workspace
- remove extra CMAKE_ARGS to fix build for qt3/kde3 users

x11/kdelibs4
- remove needless dependencies
- remove extra CMAKE_ARGS to fix build for qt3/kde3 users
2009-08-10 11:47:36 +00:00

11 lines
492 B
CMake

--- ./cmake/modules/FindLibKonq.cmake.orig 2009-05-27 21:54:40.000000000 +0200
+++ ./cmake/modules/FindLibKonq.cmake 2009-06-06 01:53:49.000000000 +0200
@@ -14,7 +14,7 @@
find_path(LIBKONQ_INCLUDE_DIR konq_popupmenuplugin.h )
-find_library(LIBKONQ_LIBRARY konq)
+find_library(LIBKONQ_LIBRARY NAMES konq PATHS ${KDE4_LIB_INSTALL_DIR} NO_DEFAULT_PATH)
include(FindPackageHandleStandardArgs)
find_package_handle_standard_args(LIBKONQ DEFAULT_MSG LIBKONQ_INCLUDE_DIR LIBKONQ_LIBRARY )