original versions of these ports, so some PORTREVISIONs were bumped. See http://freebsd.kde.org/ and mailing lists linked to from there for info on the packages generated to test these ports. bsd.kde.mk has already been updated a few days ago to work with these. Some patches applied to fix a few bugs were: deskutils/kdepim3: [1] Remove kpilot from build because it wasn't ready at release. editors/koffice-kde3: [2] Fix compile time bugs for FreeBSD. misc/kdeedu3: [3] Fix compile problem with kvoctrain. x11/kdebase3: [4] Fix KDM CPU usage and login bug. Some caveats: * All PLISTs are broken for deinstall due to script bug that I didn't notice until very recently. This will be fixed when I commit an update tomorrow. These ports should still install perfectly fine though. They should also deinstall without giving errors, but will leave directories behind. * You can't install this with any other version of QT or KDE already installed. I am not sure the checks are 100% working, but fixes for these will be forthcoming. This is mainly due to a policy decision made by kde@ to make QT/KDE ports install the way the rest of the world expects it to while also still conforming to FreeBSD's hier(7). For reference on this decision, please consult the KDE/FreeBSD mailing list archives. This decision fixes 2-year-old bug reports relating to how we handled this for KDE2 vs KDE1. Submitted by: [1] Adrian de Groot <adridg@cs.kun.nl>, [2] David Faure <faure@kde.org>, Andy Fawcett <andy@athame.co.uk> Lauri Watts <lauri@kde.org> [3] Lauri Watts <lauri@kde.org> [4] Alan Eldridge <alane@geeksrus.net> Oswald Buddenhagen <ossi@kde.org> Reviewed by: kde
33 lines
876 B
C
33 lines
876 B
C
--- ./kdm/backend/netaddr.c.orig Sun Mar 24 12:31:09 2002
|
|
+++ ./kdm/backend/netaddr.c Thu Apr 18 20:53:44 2002
|
|
@@ -216,11 +216,10 @@
|
|
#ifdef DEBUG
|
|
/*ARGSUSED*/
|
|
void
|
|
-PrintSockAddr (struct sockaddr *a, int len)
|
|
+PrintSockAddr (char *buf, struct sockaddr *a, int len)
|
|
{
|
|
unsigned char *t, *p;
|
|
|
|
- Debug ("family %d, ", a->sa_family);
|
|
switch (a->sa_family) {
|
|
#ifdef AF_INET
|
|
case AF_INET:
|
|
@@ -228,11 +227,14 @@
|
|
p = (unsigned char *) &((struct sockaddr_in *) a)->sin_port;
|
|
t = (unsigned char *) &((struct sockaddr_in *) a)->sin_addr;
|
|
|
|
- Debug ("port %d, host %d.%d.%d.%d\n",
|
|
- (p[0] << 8) + p[1], t[0], t[1], t[2], t[3]);
|
|
+ sprintf (buf, "family AF_INET, port %d, host %d.%d.%d.%d",
|
|
+ (p[0] << 8) + p[1], t[0], t[1], t[2], t[3]);
|
|
break;
|
|
- }
|
|
#endif
|
|
+ default:
|
|
+ sprintf (buf, "unknown family %d", a->sa_family);
|
|
+ break;
|
|
+ }
|
|
}
|
|
#endif
|
|
|