c07cff0ac0
- Project had moved from SF to GitHub - Build must be bootstrapped now (USES+=autoreconf) - Define LICENSE (ART20) and install CHANGES.txt - Convert two-line pkg-plist into PLIST_FILES - Remove incomplete list of games from pkg-descr Because GitHub releases (tarballs) are not fetched with correct modification time, set TIMESTAMP to 1393638577 which corresponds to commit 71f0e4c tagged as this release.
18 lines
546 B
C
18 lines
546 B
C
--- config.c.orig 2014-03-01 01:49:37 UTC
|
|
+++ config.c
|
|
@@ -192,14 +192,7 @@ qsc_load_default_config_files()
|
|
|
|
var= getenv( "HOME");
|
|
if ( var != NULL && var[0] != '\0') {
|
|
- int len= strlen(var);
|
|
- if ( len > 900)
|
|
- len= 900;
|
|
- strncpy( path, var, len);
|
|
- path[len]= '\0';
|
|
- strcat( path, "/");
|
|
- strcat( path, HOME_CONFIG_FILE);
|
|
-/* sprintf( path, "%s/%s", var, HOME_CONFIG_FILE); */
|
|
+ snprintf( path, sizeof(path), "%s/%s", var, HOME_CONFIG_FILE);
|
|
rc= try_load_config_file( path, 0);
|
|
if ( rc == 0 || rc == -1)
|
|
return rc;
|