freebsd-ports/x11-fm/rox-filer/files/patch-ROX-Filer_src_configure
Kurt Jaeger 2121e5e429 x11-fm/rox-filer: add missing dependencies and clean Makefile
- Regenerate patch files with make makepatch.
- Remove useless assignment to DISTNAME.
- Add a lib dependency on print/freetype2
- Add a lib dependency on x11-fonts/fontconfig
- Add LICENSE= GPLv2+
- Move USES ahead of USE_*
- Add gettext-runtime:build to the USES variable
- Add ice to the variable USE_XORG and sort the corresponding list
- Add cairo and gdkpixbuf2 to the variable USE_GNOME
- Reindent the lines of the target post-configure
- Split a line of the target do-install
- Replace the use of ${CHMOD} 755 in Makefile
  with the use of @(,,755) in pkg-plist

PR:		230710
Submitted by:	Samy Mahmoudi <samy.mahmoudi@gmail.com>
Approved by:	olgeni (maintainer)
2018-08-17 18:06:43 +00:00

13 lines
380 B
Text

--- ROX-Filer/src/configure.orig 2011-10-09 14:32:14 UTC
+++ ROX-Filer/src/configure
@@ -2134,10 +2134,6 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
ac_config_headers="$ac_config_headers config.h"
- if [ -f configure ]; then
- as_fn_error $? "Please run configure from the build directory (try ../AppRun --compile)" "$LINENO" 5
- exit 1
-fi
ac_ext=c
ac_cpp='$CPP $CPPFLAGS'