freebsd-ports/security/sfs/files/patch-async_aiod.h
Edwin Groothuis ef4fc524f8 Update port: security/sfs, fix build with gcc42
The attached patch fixes security/sfs so it builds with
	gcc42. The only change I made that I am wary of is commenting
	out the LIBTOOL variable in ${WRKSRC}/sfsrwcd/Makefile.
	However, this seems to work fine on both 7.0-CURRENT and
	6.2-STABLE.

	In addition, I would not mind maintaining the port.

PR:		ports/116389
Submitted by:	Dave Grochowski <malus.x@gmail.com>
2007-09-23 03:17:21 +00:00

12 lines
240 B
C++

--- async/aiod.h.orig 2002-10-29 01:29:02.000000000 -0500
+++ async/aiod.h 2007-09-15 16:53:08.000000000 -0400
@@ -30,6 +30,9 @@
#include "ihash.h"
#include "aiod_prot.h"
+class aiod;
+class aiofh;
+
struct aiod_req;
class aiobuf {