freebsd-ports/net/asterisk14/files/patch-codecs::lpc10::Makefile
2004-02-05 19:38:40 +00:00

31 lines
676 B
Text

$FreeBSD$
--- codecs/lpc10/Makefile.orig Thu Jan 8 18:52:11 2004
+++ codecs/lpc10/Makefile Fri Jan 30 02:06:54 2004
@@ -3,7 +3,7 @@
#
# default C compiler
-CC= gcc
+CC?= gcc
#
# These definitions for CFLAGS and LIB_TARGET_DIR are used when one
@@ -22,14 +22,14 @@
#
WARNINGS = -Wall -Wno-comment -Wno-error
-CFLAGS = $(OPTIMIZE) -I$(LIB_TARGET_DIR) $(WARNINGS) -fPIC
+CFLAGS += $(OPTIMIZE) -I$(LIB_TARGET_DIR) $(WARNINGS) -fPIC
#CFLAGS+= $(shell if uname -m | grep -q 86; then echo "-mpentium" ; fi)
#fix for PPC processors
ifneq ($(OSARCH),Darwin)
ifneq ($(PROC),ppc)
ifneq ($(PROC),x86_64)
- CFLAGS+= -march=$(PROC)
+ CFLAGS+=
endif
endif
endif