freebsd-ports/www/py-grequests/files/patch-setup.py
Kubilay Kocak cb4f2b7b59 www/py-grequests: Modernise and fix tests
- Enable STAGE support
- Enable AUTOPLIST support, delete pkg-plist
- RUN_DEPENDS: Use requests 2.x
- Deprecate easy_install target
- Update LICENSE (BSD2CLAUSE)
- Add TEST_DEPENDS
- Make tests work using standard setup.py test command [1]
- Backport commit for tests using requests hook **kwargs [2]

[1] https://github.com/kennethreitz/grequests/pull/47
[2] f50782ad63
2014-02-16 07:01:03 +00:00

14 lines
492 B
Python

# Support test command w/ tests_require & test_suite
# https://github.com/kennethreitz/grequests/pull/47
--- ./setup.py.orig 2014-02-16 17:35:13.772145487 +1100
+++ ./setup.py 2014-02-16 17:36:15.191123632 +1100
@@ -56,5 +56,7 @@
'Programming Language :: Python',
'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
'Topic :: Software Development :: Libraries :: Python Modules'
- ]
+ ],
+ tests_require = ['nose'],
+ test_suite = 'nose.collector',
)