freebsd-ports/japanese/zangband/files/patch-aa
Martin Wilke 3e4ed01146 - Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG
- Remove X11BASE support in favor of LOCALBASE or PREFIX
- Use USE_LDCONFIG instead of INSTALLS_SHLIB
- Remove unneeded USE_GCC 3.4+

Thanks to all Helpers:
	Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr,
	ehaupt, nox, itetcu, flz, pav

PR:		116263
Tested on:	pointyhat
Approved by:	portmgr (pav)
2008-04-19 17:56:05 +00:00

39 lines
1.1 KiB
Text

--- src/makefile.std Thu Jul 20 13:19:50 2000
+++ src/Makefile Fri Aug 11 19:54:28 2000
@@ -103,7 +103,7 @@
#
# This is my compiler of choice, it seems to work most everywhere
#
-CC = gcc
+CC ?= gcc
#
@@ -130,9 +130,9 @@
## Note: Get the 16x16.bmp file, and put in Zdirectory/lib/xtra/graf
## to get 256 colours.
##
-CFLAGS = -Wall -O2 -fno-strength-reduce -m486 -pipe -g \
- -D"USE_X11" -D"USE_GCU" -D"USE_TRANSPARENCY"
-LIBS = -lX11 -lcurses -ltermcap -L/usr/X11R6/lib
+#CFLAGS = -Wall -O2 -fno-strength-reduce -m486 -pipe -g \
+# -D"USE_X11" -D"USE_GCU" -D"USE_TRANSPARENCY"
+#LIBS = -lX11 -lcurses -ltermcap -L/usr/X11R6/lib
#CFLAGS = -Wall -O2 -fno-strength-reduce -m486 -pipe -g \
# -D"USE_XAW" -D"USE_GCU" -D"USE_TRANSPARENCY"
@@ -236,6 +236,14 @@
##
#CFLAGS = -Wall -O1 -pipe -g -D"USE_GCU" -arch m68k -arch i386
#LIBS = -lcurses -ltermcap
+
+
+
+##
+## Variation -- Compile for FreeBSD
+##
+CFLAGS += -D"USE_X11" -D"USE_GCU" -D"USE_TRANSPARENCY" ${EXTRA_CFLAGS}
+LIBS = -L${LOCALBASE}/lib -lX11 -lcurses -ltermcap