freebsd-ports/x11-toolkits/XawPlus/files/patch-test::Makefile
Greg Lewis 09bec99b16 . Add a port of XawPlus:
XawPlus is a clone of the original Xaw library, providing a more up to date
look and some extensions to the original Athena widget set. This library is
as compatible as possible to the original. It should  be possible to compile
the source code of an Xaw client without any changes (except the include path
of the XawPlus header files) to get the new look of XawPlus to this client.

XawPlus makes it possible to use XPM pixmaps, tooltips, a truncate mechanism
for too long label strings and UTF8 coded UNICODE labels without changing the
code of your application.

XawPlus comes with a set of adapted applications using also the new
features of XawPlus.

WWW: http://people.freenet.de/kra/XawPlus

PR:		47700
Submitted by:	Normal User <freebsd@falx.port5.com>
2003-09-04 14:51:06 +00:00

66 lines
2 KiB
Text

$FreeBSD$
--- test/Makefile.orig Sat Aug 10 13:14:54 2002
+++ test/Makefile Wed Jan 29 15:59:24 2003
@@ -1,13 +1,13 @@
#
-# Makefile fot the test programs
-# This makefile requires libXawPlus.a in the
-# parent directory !
+# Makefile for the test programs
#
# Roland Krause 2000
#
-LIB_PATH = -L/usr/X11/lib # Libraries for X
-INC_PATH = -I/usr/X11/include # Header for X
+PREFIX=%%X11BASE%%
+
+LIB_PATH = -L$(PREFIX)/lib # Libraries for X
+INC_PATH = -I$(PREFIX)/include # Header for X
LIBRARIES = -lXmu -lXext -lXt -lXpm -lX11
CC = gcc
@@ -19,32 +19,33 @@
# --- Compile the programs
-test_encoding: test_encoding.o ../libXawPlus.a
- $(CC) -o test_encoding $(LIB_PATH) test_encoding.o ../libXawPlus.a $(LIBRARIES)
+test_encoding: test_encoding.o $(PREFIX)/lib/libXawPlus.a
+ $(CC) -o test_encoding $(LIB_PATH) test_encoding.o $(PREFIX)/lib/libXawPlus.a $(LIBRARIES)
test_encoding.o:test_encoding.c
$(CC) $(FLAGS) $(INC_PATH) -c test_encoding.c
-test_pixmap: test_pixmap.o ../libXawPlus.a
- $(CC) -o test_pixmap $(LIB_PATH) test_pixmap.o ../libXawPlus.a $(LIBRARIES)
+test_pixmap: test_pixmap.o $(PREFIX)/lib/libXawPlus.a
+ $(CC) -o test_pixmap $(LIB_PATH) test_pixmap.o $(PREFIX)/lib/libXawPlus.a $(LIBRARIES)
test_pixmap.o: test_pixmap.c
$(CC) $(FLAGS) $(INC_PATH) -c test_pixmap.c
-test_scrbar: test_scrbar.o ../libXawPlus.a
- $(CC) -o test_scrbar $(LIB_PATH) test_scrbar.o ../libXawPlus.a $(LIBRARIES)
+test_scrbar: test_scrbar.o $(PREFIX)/lib/libXawPlus.a
+ $(CC) -o test_scrbar $(LIB_PATH) test_scrbar.o $(PREFIX)/lib/libXawPlus.a $(LIBRARIES)
test_scrbar.o: test_scrbar.c
$(CC) $(FLAGS) $(INC_PATH) -c test_scrbar.c
-test_menu: test_menu.o ../libXawPlus.a
- $(CC) -o test_menu $(LIB_PATH) test_menu.o ../libXawPlus.a $(LIBRARIES)
+test_menu: test_menu.o $(PREFIX)/lib/libXawPlus.a
+ $(CC) -o test_menu $(LIB_PATH) test_menu.o $(PREFIX)/lib/libXawPlus.a $(LIBRARIES)
test_menu.o: test_menu.c
$(CC) $(FLAGS) $(INC_PATH) -c test_menu.c
-
# --- Clean up
+
+.PHONY: clean
clean:
rm -f *.o $(PROGS)