- VMailMgr (short for Virtual MAIL ManaGeR) is a package of programs designed to manage multiple domains of mail addresses and mailboxes on a single host. It co-operates with qmail for mail delivery and program control. - It features: - A password checking interface between qmail-popup and qmail-pop3d which replaces the usual checkpassword, as well as an authentication module for Courier IMAP, that provide access to the virtual mailboxes by one of three methods: IP-based virtual server access (invisible to the POP3 user) username-based access (username-virtualuser) hostname-based access (virtualuser@virtual.host or virtualuser:virtual.host) - CDB-based password tables to speed up access for domains of any size. - Tools to setup a virtual domain, add and delete individual virtual users and aliases, and to change passwords. CGI programs to accomplish the above tasks from a set of web pages. - A native PHP library to compliment or replace the CGIs. - A daemon process that securely directs the operation of the CGIs and PHP code. - A separate delivery agent that automatically deals with any address inside a virtual domain from a single .qmail-default file. WWW: http://www.vmailmgr.org PR: ports/117509 Submitted by: Mij <mij@bitchx.it> (maintainer) Approved by: linimon (mentor)
175 lines
6.5 KiB
Diff
175 lines
6.5 KiB
Diff
diff -ruN ../vmailmgr-0.97_orig/Makefile.am ./Makefile.am
|
|
--- ../vmailmgr-0.97_orig/Makefile.am 2007-10-24 23:10:21.000000000 +0200
|
|
+++ ./Makefile.am 2007-10-25 00:28:41.000000000 +0200
|
|
@@ -1,7 +1,7 @@
|
|
if WANTPYTHON
|
|
-SUBDIRS = python php lib authenticate commands daemon cgi doc scripts
|
|
+SUBDIRS = python lib authenticate commands daemon cgi doc scripts
|
|
else
|
|
-SUBDIRS = php lib authenticate commands daemon cgi doc scripts
|
|
+SUBDIRS = lib authenticate commands daemon cgi doc scripts
|
|
endif
|
|
|
|
dist-hook:
|
|
diff -ruN ../vmailmgr-0.97_orig/authenticate/Makefile.am ./authenticate/Makefile.am
|
|
--- ../vmailmgr-0.97_orig/authenticate/Makefile.am 2007-10-24 23:10:20.000000000 +0200
|
|
+++ ./authenticate/Makefile.am 2007-10-25 01:14:12.000000000 +0200
|
|
@@ -1,5 +1,5 @@
|
|
bin_PROGRAMS = checkvpw vauthenticate
|
|
-authlib_PROGRAMS = authvmailmgr
|
|
+#authlib_PROGRAMS = authvmailmgr
|
|
authlibdir = ${prefix}/lib/courier-imap/libexec/authlib/
|
|
|
|
noinst_PODS = checkvpw.pod vauthenticate.pod
|
|
@@ -25,8 +25,8 @@
|
|
checkvpw_SOURCES = checkvpw.cc authvlib.cc authvlib.h
|
|
checkvpw_LDADD = ../lib/libvmailmgr.a
|
|
|
|
-authvmailmgr_SOURCES = authvmailmgr.cc authvlib.cc authvlib.h
|
|
-authvmailmgr_LDADD = ../lib/libvmailmgr.a -L../lib/courier-authlib -lauthmod
|
|
+#authvmailmgr_SOURCES = authvmailmgr.cc authvlib.cc authvlib.h
|
|
+#authvmailmgr_LDADD = ../lib/libvmailmgr.a -L../lib/courier-authlib -lauthmod
|
|
|
|
vauthenticate_SOURCES = vauthenticate.cc authvlib.cc authvlib.h
|
|
vauthenticate_LDADD = ../lib/libvmailmgr.a
|
|
diff -ruN ../vmailmgr-0.97_orig/cgi/Makefile.am ./cgi/Makefile.am
|
|
--- ../vmailmgr-0.97_orig/cgi/Makefile.am 2007-10-24 23:10:21.000000000 +0200
|
|
+++ ./cgi/Makefile.am 2007-10-25 01:25:01.000000000 +0200
|
|
@@ -1,5 +1,6 @@
|
|
EXTRA_DIST = listvdomain.html vaddalias.html vadduser.html vchalias.html \
|
|
vchattr.html vchforwards.html vdeluser.html vpasswd.html
|
|
+cgidir=$(PREFIX)/libexec/vmailmgr/cgi-bin
|
|
cgi_PROGRAMS = vpasswd vadduser vdeluser vaddalias vchattr vchforwards \
|
|
listvdomain
|
|
|
|
diff -ruN ../vmailmgr-0.97_orig/commands/vdeliver.cc ./commands/vdeliver.cc
|
|
--- ../vmailmgr-0.97_orig/commands/vdeliver.cc 2007-10-24 23:10:20.000000000 +0200
|
|
+++ ./commands/vdeliver.cc 2007-10-25 00:30:33.000000000 +0200
|
|
@@ -262,7 +262,7 @@
|
|
close(pipe2[1]);
|
|
if((dup2(pipe1[0], 0) != 0) || (dup2(pipe2[0], 1) != 1))
|
|
exit(111);
|
|
- execl(qq.c_str(), qq.c_str(), 0);
|
|
+ execl(qq.c_str(), qq.c_str(), (char *)0);
|
|
die_temp("Exec of qmail-queue failed.");
|
|
default:
|
|
close(pipe1[0]);
|
|
diff -ruN ../vmailmgr-0.97_orig/configure.in ./configure.in
|
|
--- ../vmailmgr-0.97_orig/configure.in 2007-10-24 23:10:21.000000000 +0200
|
|
+++ ./configure.in 2007-10-25 00:50:29.000000000 +0200
|
|
@@ -62,27 +62,27 @@
|
|
AC_SUBST(pythonlibdir)
|
|
AM_CONDITIONAL(WANTPYTHON, test x$local_cv_python_lib_dir != xNONE)
|
|
|
|
-phpdir="/home/httpd/php"
|
|
-AC_SUBST(phpdir)
|
|
-
|
|
AC_PATH_PROG(W3M, w3m)
|
|
AC_PATH_PROG(LYNX, lynx)
|
|
if test "x$W3M" != x; then
|
|
echo Using w3m to format html pages.
|
|
- HTML2TXT="w3m -dump"
|
|
+ HTML2TXT=$W3M" -dump"
|
|
elif test "x$LYNX" != x; then
|
|
echo Using lynx to format html pages.
|
|
- HTML2TXT="lynx -dump -nolist"
|
|
+ HTML2TXT=$LYNX" -dump -nolist"
|
|
else
|
|
echo "Can't find either w3m or lynx, building the plain text"
|
|
echo "documentation files will fail."
|
|
HTML2TXT="false"
|
|
fi
|
|
AC_SUBST(HTML2TXT)
|
|
+AM_CONDITIONAL(MAKE_TXTS, test x$HTML2TXT != xfalse)
|
|
|
|
TODAY=`date +%Y-%m-%d`
|
|
-POD2MAN="pod2man --release='vmailmgr ${VERSION}' --center='VMailMgr Tools Documentation' --date='${TODAY}'"
|
|
-POD2HTML="pod2html --noindex"
|
|
+AC_PATH_PROG(POD2MAN,pod2man)
|
|
+AC_PATH_PROG(POD2HTML,pod2html)
|
|
+POD2MAN=$POD2MAN" --release='vmailmgr ${VERSION}' --center='VMailMgr Tools Documentation' --date='${TODAY}'"
|
|
+POD2HTML=$POD2HTML" --noindex"
|
|
SUFFIXES="$SUFFIXES .1 .5 .7 .8 .pod .html .texi .txt .ps .fig .sgml .py .pyc .pyo"
|
|
AC_SUBST(POD2MAN)
|
|
AC_SUBST(POD2HTML)
|
|
@@ -135,5 +135,4 @@
|
|
lib/vpwentry/Makefile
|
|
lib/vpwtable/Makefile
|
|
scripts/Makefile
|
|
- php/Makefile
|
|
python/Makefile)
|
|
diff -ruN ../vmailmgr-0.97_orig/doc/Makefile.am ./doc/Makefile.am
|
|
--- ../vmailmgr-0.97_orig/doc/Makefile.am 2007-10-24 23:10:21.000000000 +0200
|
|
+++ ./doc/Makefile.am 2007-10-25 00:29:38.000000000 +0200
|
|
@@ -2,21 +2,23 @@
|
|
noinst_TEXINFOS = FAQ.texi HOWTO.texi configuration.texi vmailmgr-cgi.texi
|
|
noinst_HTMLS = vmailmgr.html HOWTO.html FAQ.html NEWS.html \
|
|
configuration.html ChangeLog.html vmailmgr-cgi.html
|
|
+if MAKE_TXTS
|
|
noinst_TXTS = HOWTO.txt FAQ.txt \
|
|
configuration.txt vmailmgr-cgi.txt protocol.txt \
|
|
record-format.txt
|
|
+else
|
|
+noinst_TXTS =
|
|
+endif
|
|
noinst_PODS = vmailmgr.pod
|
|
-noinst_MISC = FAQ.info FAQ.pdf HOWTO.info HOWTO.pdf \
|
|
- configuration.info translation.pdf translation.ps
|
|
+noinst_MISC = FAQ.info HOWTO.info configuration.info
|
|
EXTRA_DIST = ChangeLog-pre-vmailmgr ChangeLog-pre-0.70 \
|
|
changelog2html.pl news2html.pl \
|
|
- YEAR2000 translation.fig \
|
|
+ YEAR2000 \
|
|
$(man_MANS) \
|
|
$(noinst_PODS) \
|
|
$(noinst_TEXINFOS) \
|
|
$(noinst_HTMLS) \
|
|
- $(noinst_MISC) \
|
|
- $(noinst_TXTS)
|
|
+ $(noinst_MISC) $(noinst_TXTS)
|
|
CLEANFILES = $(noinst_HTMLS) $(man_MANS) $(noinst_MISC) \
|
|
HOWTO.txt FAQ.txt configuration.txt vmailmgr-cgi.txt \
|
|
pod2htmd.tmp pod2htmi.tmp
|
|
diff -ruN ../vmailmgr-0.97_orig/lib/fdbuf/fdobuf.h ./lib/fdbuf/fdobuf.h
|
|
--- ../vmailmgr-0.97_orig/lib/fdbuf/fdobuf.h 2007-10-24 23:10:20.000000000 +0200
|
|
+++ ./lib/fdbuf/fdobuf.h 2007-10-25 00:31:00.000000000 +0200
|
|
@@ -18,6 +18,8 @@
|
|
#ifndef FDBUF__FDOBUF__H__
|
|
#define FDBUF__FDOBUF__H__
|
|
|
|
+#include <sys/types.h>
|
|
+
|
|
class fdobuf : protected fdbuf
|
|
{
|
|
public:
|
|
diff -ruN ../vmailmgr-0.97_orig/lib/misc/maildir.cc ./lib/misc/maildir.cc
|
|
--- ../vmailmgr-0.97_orig/lib/misc/maildir.cc 2007-10-24 23:10:20.000000000 +0200
|
|
+++ ./lib/misc/maildir.cc 2007-10-25 00:32:17.000000000 +0200
|
|
@@ -36,7 +36,7 @@
|
|
if(mkdirp(dirname.left(i), 0755))
|
|
return -1;
|
|
}
|
|
- if(i != dirname.length() - 1)
|
|
+ if(i != (int)dirname.length() - 1)
|
|
return mkdir(dirname.c_str(), mode);
|
|
return 0;
|
|
}
|
|
diff -ruN ../vmailmgr-0.97_orig/lib/misc/server.cc ./lib/misc/server.cc
|
|
--- ../vmailmgr-0.97_orig/lib/misc/server.cc 2007-10-24 23:10:20.000000000 +0200
|
|
+++ ./lib/misc/server.cc 2007-10-25 00:30:44.000000000 +0200
|
|
@@ -17,6 +17,7 @@
|
|
#include <config.h>
|
|
#include "server.h"
|
|
#include <stdlib.h>
|
|
+#include <string.h>
|
|
#include <unistd.h>
|
|
#include "un.h"
|
|
#include "debug.h"
|
|
diff -ruN ../vmailmgr-0.97_orig/php/Makefile.am ./php/Makefile.am
|
|
--- ../vmailmgr-0.97_orig/php/Makefile.am 2007-10-24 23:10:21.000000000 +0200
|
|
+++ ./php/Makefile.am 2007-10-25 01:26:19.000000000 +0200
|
|
@@ -1,3 +1,4 @@
|
|
+phpdir=$(PREFIX)/libexec/vmailmgr/php/
|
|
php_DATA = vmail.inc
|
|
EXTRA_DIST = vmail.features vmail.inc
|
|
|