This captures some gcc fixes in the 2 months since the release. The version info with --version option has also been restored.
342 lines
12 KiB
Text
342 lines
12 KiB
Text
--- gcc/config/dragonfly.h.orig
|
|
+++ gcc/config/dragonfly.h
|
|
@@ -84,7 +84,7 @@
|
|
} \
|
|
%{static:-Bstatic} \
|
|
} \
|
|
- %{!static:--hash-style=gnu} \
|
|
+ %{!static:--hash-style=gnu -rpath @PREFIX@/@GCCAUX@/lib} \
|
|
%{symbolic:-Bsymbolic}"
|
|
|
|
#undef LINK_SPEC
|
|
--- gcc/config/i386/freebsd.h.orig
|
|
+++ gcc/config/i386/freebsd.h
|
|
@@ -90,6 +90,14 @@
|
|
When the -shared link option is used a final link is not being
|
|
done. */
|
|
|
|
+#if FBSD_MAJOR < 9
|
|
+#define ELF_HASH_STYLE ""
|
|
+#elif FBSD_MAJOR < 10
|
|
+#define ELF_HASH_STYLE "--hash-style=both "
|
|
+#else
|
|
+#define ELF_HASH_STYLE "--hash-style=gnu "
|
|
+#endif
|
|
+
|
|
#undef LINK_SPEC
|
|
#define LINK_SPEC "\
|
|
%{p:%nconsider using '-pg' instead of '-p' with gprof(1)} \
|
|
@@ -101,6 +109,7 @@
|
|
%{rdynamic:-export-dynamic} \
|
|
-dynamic-linker %(fbsd_dynamic_linker) } \
|
|
%{static:-Bstatic}} \
|
|
+ %{!static:" ELF_HASH_STYLE "-rpath @PREFIX@/@GCCAUX@/lib} \
|
|
%{symbolic:-Bsymbolic}"
|
|
|
|
/* A C statement to output to the stdio stream FILE an assembler
|
|
--- gcc/config/i386/freebsd64.h.orig
|
|
+++ gcc/config/i386/freebsd64.h
|
|
@@ -41,4 +41,5 @@
|
|
%{rdynamic:-export-dynamic} \
|
|
-dynamic-linker %(fbsd_dynamic_linker) } \
|
|
%{static:-Bstatic}} \
|
|
+ %{!static:" ELF_HASH_STYLE "-rpath @PREFIX@/@GCCAUX@/lib} \
|
|
%{symbolic:-Bsymbolic}"
|
|
--- /dev/null
|
|
+++ libgcc/config/i386/freebsd-unwind.h
|
|
@@ -0,0 +1,173 @@
|
|
+/* DWARF2 EH unwinding support for FreeBSD: AMD x86-64 and x86.
|
|
+ Copyright (C) 2015 Free Software Foundation, Inc.
|
|
+ Contributed by John Marino <gnugcc@marino.st>
|
|
+
|
|
+This file is part of GCC.
|
|
+
|
|
+GCC is free software; you can redistribute it and/or modify
|
|
+it under the terms of the GNU General Public License as published by
|
|
+the Free Software Foundation; either version 3, or (at your option)
|
|
+any later version.
|
|
+
|
|
+GCC is distributed in the hope that it will be useful,
|
|
+but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+GNU General Public License for more details.
|
|
+
|
|
+Under Section 7 of GPL version 3, you are granted additional
|
|
+permissions described in the GCC Runtime Library Exception, version
|
|
+3.1, as published by the Free Software Foundation.
|
|
+
|
|
+You should have received a copy of the GNU General Public License and
|
|
+a copy of the GCC Runtime Library Exception along with this program;
|
|
+see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
|
+<http://www.gnu.org/licenses/>. */
|
|
+
|
|
+/* Do code reading to identify a signal frame, and set the frame
|
|
+ state data appropriately. See unwind-dw2.c for the structs. */
|
|
+
|
|
+#include <sys/types.h>
|
|
+#include <signal.h>
|
|
+#include <sys/ucontext.h>
|
|
+#include <machine/sigframe.h>
|
|
+
|
|
+#define REG_NAME(reg) sf_uc.uc_mcontext.mc_## reg
|
|
+
|
|
+#ifdef __x86_64__
|
|
+#define MD_FALLBACK_FRAME_STATE_FOR x86_64_freebsd_fallback_frame_state
|
|
+
|
|
+static _Unwind_Reason_Code
|
|
+x86_64_freebsd_fallback_frame_state
|
|
+(struct _Unwind_Context *context, _Unwind_FrameState *fs)
|
|
+{
|
|
+ struct sigframe *sf;
|
|
+ long new_cfa;
|
|
+
|
|
+ /* Prior to FreeBSD 9, the signal trampoline was located immediately
|
|
+ before the ps_strings. To support non-executable stacks on AMD64,
|
|
+ the sigtramp was moved to a shared page for FreeBSD 9. Unfortunately
|
|
+ this means looking frame patterns again (sys/amd64/amd64/sigtramp.S)
|
|
+ rather than using the robust and convenient KERN_PS_STRINGS trick.
|
|
+
|
|
+ <pc + 00>: lea 0x10(%rsp),%rdi
|
|
+ <pc + 05>: pushq $0x0
|
|
+ <pc + 17>: mov $0x1a1,%rax
|
|
+ <pc + 14>: syscall
|
|
+
|
|
+ If we can't find this pattern, we're at the end of the stack.
|
|
+ */
|
|
+
|
|
+ if (!( *(unsigned int *)(context->ra) == 0x247c8d48
|
|
+ && *(unsigned int *)(context->ra + 4) == 0x48006a10
|
|
+ && *(unsigned int *)(context->ra + 8) == 0x01a1c0c7
|
|
+ && *(unsigned int *)(context->ra + 12) == 0x050f0000 ))
|
|
+ return _URC_END_OF_STACK;
|
|
+
|
|
+ sf = (struct sigframe *) context->cfa;
|
|
+ new_cfa = sf->REG_NAME(rsp);
|
|
+ fs->regs.cfa_how = CFA_REG_OFFSET;
|
|
+ /* Register 7 is rsp */
|
|
+ fs->regs.cfa_reg = 7;
|
|
+ fs->regs.cfa_offset = new_cfa - (long) context->cfa;
|
|
+
|
|
+ /* The SVR4 register numbering macros aren't usable in libgcc. */
|
|
+ fs->regs.reg[0].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[0].loc.offset = (long)&sf->REG_NAME(rax) - new_cfa;
|
|
+ fs->regs.reg[1].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[1].loc.offset = (long)&sf->REG_NAME(rdx) - new_cfa;
|
|
+ fs->regs.reg[2].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[2].loc.offset = (long)&sf->REG_NAME(rcx) - new_cfa;
|
|
+ fs->regs.reg[3].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[3].loc.offset = (long)&sf->REG_NAME(rbx) - new_cfa;
|
|
+ fs->regs.reg[4].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[4].loc.offset = (long)&sf->REG_NAME(rsi) - new_cfa;
|
|
+ fs->regs.reg[5].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[5].loc.offset = (long)&sf->REG_NAME(rdi) - new_cfa;
|
|
+ fs->regs.reg[6].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[6].loc.offset = (long)&sf->REG_NAME(rbp) - new_cfa;
|
|
+ fs->regs.reg[8].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[8].loc.offset = (long)&sf->REG_NAME(r8) - new_cfa;
|
|
+ fs->regs.reg[9].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[9].loc.offset = (long)&sf->REG_NAME(r9) - new_cfa;
|
|
+ fs->regs.reg[10].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[10].loc.offset = (long)&sf->REG_NAME(r10) - new_cfa;
|
|
+ fs->regs.reg[11].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[11].loc.offset = (long)&sf->REG_NAME(r11) - new_cfa;
|
|
+ fs->regs.reg[12].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[12].loc.offset = (long)&sf->REG_NAME(r12) - new_cfa;
|
|
+ fs->regs.reg[13].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[13].loc.offset = (long)&sf->REG_NAME(r13) - new_cfa;
|
|
+ fs->regs.reg[14].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[14].loc.offset = (long)&sf->REG_NAME(r14) - new_cfa;
|
|
+ fs->regs.reg[15].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[15].loc.offset = (long)&sf->REG_NAME(r15) - new_cfa;
|
|
+ fs->regs.reg[16].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[16].loc.offset = (long)&sf->REG_NAME(rip) - new_cfa;
|
|
+ fs->retaddr_column = 16;
|
|
+ fs->signal_frame = 1;
|
|
+ return _URC_NO_REASON;
|
|
+}
|
|
+
|
|
+#else /* Next section is for i386 */
|
|
+
|
|
+#define MD_FALLBACK_FRAME_STATE_FOR x86_freebsd_fallback_frame_state
|
|
+
|
|
+/*
|
|
+ * We can't use KERN_PS_STRINGS anymore if we want to support FreeBSD32
|
|
+ * compat on AMD64. The sigtramp is in a shared page in that case so the
|
|
+ * x86_sigtramp_range only works on a true i386 system. We have to
|
|
+ * search for the sigtramp frame if we want it working everywhere.
|
|
+ */
|
|
+
|
|
+static _Unwind_Reason_Code
|
|
+x86_freebsd_fallback_frame_state
|
|
+(struct _Unwind_Context *context, _Unwind_FrameState *fs)
|
|
+{
|
|
+ struct sigframe *sf;
|
|
+ long new_cfa;
|
|
+
|
|
+/*
|
|
+ * i386 sigtramp frame we are looking for follows.
|
|
+ * Apparently PSL_VM is variable, so we can't look past context->ra + 4
|
|
+ * <sigcode>:
|
|
+ * 0: ff 54 24 10 call *0x10(%esp) *SIGF_HANDLER
|
|
+ * 4: 8d 44 24 20 lea 0x20(%esp),%eax SIGF_UC
|
|
+ * 8: 50 push %eax
|
|
+ * 9: f7 40 54 00 00 02 00 testl $0x20000,0x54(%eax) $PSL_VM
|
|
+ * 10: 75 03 jne 15 <sigcode+0x15>
|
|
+ * 12: 8e 68 14 mov 0x14(%eax),%gs UC_GS
|
|
+ * 15: b8 a1 01 00 00 mov 0x1a1,%eax $SYS_sigreturn
|
|
+ */
|
|
+
|
|
+ if (!( *(unsigned int *)(context->ra - 4) == 0x102454ff
|
|
+ && *(unsigned int *)(context->ra) == 0x2024448d ))
|
|
+ return _URC_END_OF_STACK;
|
|
+
|
|
+ sf = (struct sigframe *) context->cfa;
|
|
+ new_cfa = sf->REG_NAME(esp);
|
|
+ fs->regs.cfa_how = CFA_REG_OFFSET;
|
|
+ fs->regs.cfa_reg = 4;
|
|
+ fs->regs.cfa_offset = new_cfa - (long) context->cfa;
|
|
+
|
|
+ /* The SVR4 register numbering macros aren't usable in libgcc. */
|
|
+ fs->regs.reg[0].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[0].loc.offset = (long)&sf->REG_NAME(eax) - new_cfa;
|
|
+ fs->regs.reg[3].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[3].loc.offset = (long)&sf->REG_NAME(ebx) - new_cfa;
|
|
+ fs->regs.reg[1].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[1].loc.offset = (long)&sf->REG_NAME(ecx) - new_cfa;
|
|
+ fs->regs.reg[2].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[2].loc.offset = (long)&sf->REG_NAME(edx) - new_cfa;
|
|
+ fs->regs.reg[6].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[6].loc.offset = (long)&sf->REG_NAME(esi) - new_cfa;
|
|
+ fs->regs.reg[7].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[7].loc.offset = (long)&sf->REG_NAME(edi) - new_cfa;
|
|
+ fs->regs.reg[5].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[5].loc.offset = (long)&sf->REG_NAME(ebp) - new_cfa;
|
|
+ fs->regs.reg[8].how = REG_SAVED_OFFSET;
|
|
+ fs->regs.reg[8].loc.offset = (long)&sf->REG_NAME(eip) - new_cfa;
|
|
+ fs->retaddr_column = 8;
|
|
+ fs->signal_frame = 1;
|
|
+ return _URC_NO_REASON;
|
|
+}
|
|
+#endif /* ifdef __x86_64__ */
|
|
--- libiberty/getpagesize.c.orig
|
|
+++ libiberty/getpagesize.c
|
|
@@ -20,6 +20,7 @@
|
|
|
|
*/
|
|
|
|
+#ifndef __ANDROID__
|
|
#ifndef VMS
|
|
|
|
#include "config.h"
|
|
@@ -88,3 +89,4 @@
|
|
}
|
|
|
|
#endif /* VMS */
|
|
+#endif /* __ANDROID__ */
|
|
--- libiberty/setproctitle.c.orig
|
|
+++ libiberty/setproctitle.c
|
|
@@ -40,9 +40,11 @@
|
|
void
|
|
setproctitle (const char *name ATTRIBUTE_UNUSED, ...)
|
|
{
|
|
+#ifndef __ANDROID__
|
|
#ifdef PR_SET_NAME
|
|
/* On GNU/Linux this sets the top visible "comm", but not
|
|
necessarily the name visible in ps. */
|
|
prctl (PR_SET_NAME, name);
|
|
#endif
|
|
+#endif
|
|
}
|
|
--- gcc/Makefile.in.orig
|
|
+++ gcc/Makefile.in
|
|
@@ -1163,7 +1163,6 @@
|
|
insn-emit.o \
|
|
insn-extract.o \
|
|
insn-latencytab.o \
|
|
- insn-modes.o \
|
|
insn-opinit.o \
|
|
insn-output.o \
|
|
insn-peep.o \
|
|
@@ -1518,6 +1517,7 @@
|
|
$(OBJS-libcommon-target) @TREEBROWSER@ main.o c-family/cppspec.o \
|
|
$(COLLECT2_OBJS) $(EXTRA_GCC_OBJS) $(GCOV_OBJS) $(GCOV_DUMP_OBJS) \
|
|
$(GCOV_TOOL_OBJS) $(GENGTYPE_OBJS) gcc-ar.o gcc-nm.o gcc-ranlib.o \
|
|
+ insn-modes.o insn-modes-ada.o \
|
|
lto-wrapper.o collect-utils.o
|
|
|
|
# This lists all host object files, whether they are included in this
|
|
@@ -1525,6 +1525,11 @@
|
|
ALL_HOST_OBJS = $(ALL_HOST_FRONTEND_OBJS) $(ALL_HOST_BACKEND_OBJS)
|
|
|
|
BACKEND = libbackend.a main.o @TREEBROWSER@ libcommon-target.a libcommon.a \
|
|
+ insn-modes.o \
|
|
+ $(CPPLIB) $(LIBDECNUMBER)
|
|
+
|
|
+BACKEND2 = libbackend.a main.o @TREEBROWSER@ libcommon-target.a libcommon.a \
|
|
+ insn-modes-ada.o \
|
|
$(CPPLIB) $(LIBDECNUMBER)
|
|
|
|
# This is defined to "yes" if Tree checking is enabled, which roughly means
|
|
@@ -2171,6 +2176,7 @@
|
|
|
|
insn-modes.c: s-modes; @true
|
|
insn-modes.h: s-modes-h; @true
|
|
+insn-modes-ada.c: s-modes-ada; @true
|
|
min-insn-modes.c: s-modes-m; @true
|
|
|
|
s-modes: build/genmodes$(build_exeext)
|
|
@@ -2188,6 +2194,12 @@
|
|
$(SHELL) $(srcdir)/../move-if-change tmp-min-modes.c min-insn-modes.c
|
|
$(STAMP) s-modes-m
|
|
|
|
+s-modes-ada: s-modes
|
|
+ $(shell sed -e 's/: TARGET_96_ROUND_53_LONG_DOUBLE \? &ieee_extended_intel_96_round_53_format //' \
|
|
+ < insn-modes.c > tmp-modes-ada.c)
|
|
+ $(SHELL) $(srcdir)/../move-if-change tmp-modes-ada.c insn-modes-ada.c
|
|
+ $(STAMP) s-modes-ada
|
|
+
|
|
insn-preds.c: s-preds; @true
|
|
tm-preds.h: s-preds-h; @true
|
|
tm-constrs.h: s-constrs-h; @true
|
|
@@ -3333,6 +3345,9 @@
|
|
( cd $(DESTDIR)$(bindir) && \
|
|
$(LN) $(GCC_INSTALL_NAME)$(exeext) $(FULL_DRIVER_NAME) ); \
|
|
fi; \
|
|
+ if [ -f gnat1$(exeext) ] ; then \
|
|
+ ( cd $(DESTDIR)$(bindir) && $(LN) $(GCC_INSTALL_NAME)$(exeext) ada$(exeext) ) \
|
|
+ fi; \
|
|
if [ ! -f gcc-cross$(exeext) ] \
|
|
&& [ "$(GCC_INSTALL_NAME)" != "$(GCC_TARGET_INSTALL_NAME)" ]; then \
|
|
rm -f $(DESTDIR)$(bindir)/$(target_noncanonical)-gcc-tmp$(exeext); \
|
|
--- libgcc/config.host.orig
|
|
+++ libgcc/config.host
|
|
@@ -240,7 +240,8 @@
|
|
extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
|
|
;;
|
|
*-*-netbsd*)
|
|
- tmake_file="$tmake_file t-crtstuff-pic t-libgcc-pic t-slibgcc t-slibgcc-gld t-slibgcc-elf-ver"
|
|
+ tmake_file="$tmake_file t-crtstuff-pic t-libgcc-pic t-eh-dw2-dip"
|
|
+ tmake_file="$tmake_file t-slibgcc t-slibgcc-gld t-slibgcc-elf-ver"
|
|
# NetBSD 1.7 and later are set up to use GCC's crtstuff for
|
|
# ELF configurations. We will clear extra_parts in the
|
|
# a.out configurations.
|
|
@@ -567,14 +568,19 @@
|
|
;;
|
|
i[34567]86-*-freebsd*)
|
|
tmake_file="${tmake_file} i386/t-freebsd i386/t-crtstuff"
|
|
+ md_unwind_header=i386/freebsd-unwind.h
|
|
;;
|
|
x86_64-*-freebsd*)
|
|
tmake_file="${tmake_file} i386/t-freebsd i386/t-crtstuff"
|
|
+ md_unwind_header=i386/freebsd-unwind.h
|
|
;;
|
|
i[34567]86-*-netbsdelf*)
|
|
+ tmake_file="${tmake_file} i386/t-crtstuff"
|
|
+ md_unwind_header=i386/netbsd-unwind.h
|
|
;;
|
|
x86_64-*-netbsd*)
|
|
tmake_file="${tmake_file} i386/t-crtstuff"
|
|
+ md_unwind_header=i386/netbsd-unwind.h
|
|
;;
|
|
i[34567]86-*-openbsd2.*|i[34567]86-*openbsd3.[0123])
|
|
;;
|