5e5119c4f0
The X-Plane Scenery Tools (XPTools) code base is the source code tree for all of the Laminar Research scenery creation/editing tools. This code does not include X-Plane and the "X-Apps" (PlaneMaker, WorldMaker, AirfoilMaker, and Briefer). It does include source to the ac3d x-plane plugin, WED, the various tools, and our global scenery generator. WWW: https://developer.x-plane.com/code/ PR: 223649 Submitted by: Michael Danilov <mike.d.ft402@gmail.com>
20 lines
647 B
Makefile
20 lines
647 B
Makefile
--- makerules/global/paths.mk.orig 2017-04-14 14:21:02 UTC
|
|
+++ makerules/global/paths.mk
|
|
@@ -2,6 +2,8 @@
|
|
# project wide include and library searchpaths
|
|
##############################################
|
|
|
|
+LIBPATHS += -L${PREFIX}/lib
|
|
+LIBPATHS += -L${PREFIX}/lib/qt4
|
|
LIBPATHS += -L./libs/local$(MULTI_SUFFIX)/lib
|
|
|
|
INCLUDEPATHS += -I./libs/local$(MULTI_SUFFIX)/include
|
|
@@ -43,5 +44,7 @@
|
|
|
|
ifdef PLAT_LINUX
|
|
INCLUDEPATHS += -I./libs/local$(MULTI_SUFFIX)/include/mesa
|
|
-INCLUDEPATHS += -I/usr/include/qt4
|
|
+INCLUDEPATHS += -I${PREFIX}/include
|
|
+INCLUDEPATHS += -I${PREFIX}/include/qt4
|
|
+INCLUDEPATHS += -I${PREFIX}/include/freetype2
|
|
endif #PLAT_LINUX
|