Some port changes include: o Removed port dependency on patch files. o Added LIB_DEPENDS for requiring pcre to build services. o Added CONFIGURE_ENV options to help configure detect sqlite and pcre libs and header files. o Added PERL dependency for database schema generation scripts on port installation. o Added new Memoserv configure options. o Restored MySQL database backend support. o Fixed build error caused when building with 'NOPORTDOCS=yes'. Brief list of some package changes: o Multi-language support - Support for different language translations of services help files and responses (currently not recommended in this release). o Memoserv - A new service allowing usernames to send memos to each other. o Service merging - Ability to merge services like banserv, jupeserv and watchserv into operserv. o Regexp - Ability to add regular expression ban matches. o Suspend - Ability to suspend users and channels. PR: ports/125035 Submitted by: Lewis <moggie@elasticmind.net> (maintainer)
21 lines
664 B
Text
21 lines
664 B
Text
--- ./langs/Makefile.in.orig 2008-06-26 13:29:27.000000000 +0100
|
|
+++ ./langs/Makefile.in 2008-06-26 13:30:48.000000000 +0100
|
|
@@ -12,17 +12,8 @@
|
|
LANGS=bg.lang ru.lang
|
|
|
|
install:
|
|
- @if [ -d $(DESTDIR)$(langdir)-old ]; then \
|
|
- echo "Removing old translations"; \
|
|
- $(RM) -rf $(DESTDIR)$(langdir)-old; \
|
|
- fi
|
|
- @if [ -d $(DESTDIR)$(langdir) ]; then \
|
|
- echo "Backing up current translations"; \
|
|
- $(MV) $(DESTDIR)$(langdir) $(DESTDIR)$(langdir)-old; \
|
|
- fi
|
|
-
|
|
@echo "Installing new translations"
|
|
- @$(INSTALL) -m 750 -d $(DESTDIR)$(langdir)
|
|
+ @$(INSTALL) -d $(DESTDIR)$(langdir)
|
|
|
|
@for k in $(LANGS); do \
|
|
$(INSTALL_DATA) $$k $(DESTDIR)$(langdir)/$$k; \
|