freebsd-ports/games/doom/files/patch-Makefile
Martin Wilke 72ddf7d5d7 - Remove some patches as I added them as REINPLACE_
- Rename the patches to make them less confusing
- Add a hack to replace all %%LOCALBASE%% to ${LOCALBASE}

PR:		140233
Submitted by:	Chris Petrik <chris@officialunix.com> (maintainer)
2009-11-04 08:37:24 +00:00

26 lines
731 B
Text

--- linuxdoom-1.10/Makefile.orig Mon Dec 22 20:55:36 1997
+++ linuxdoom-1.10/Makefile Fri Oct 28 12:44:09 2005
@@ -4,11 +4,12 @@
#
# $Log:$
#
-CC= gcc # gcc or g++
+CC?= gcc # gcc or g++
-CFLAGS=-g -Wall -DNORMALUNIX -DLINUX # -DUSEASM
-LDFLAGS=-L/usr/X11R6/lib
-LIBS=-lXext -lX11 -lnsl -lm
+CFLAGS?= -O
+CFLAGS+=-g -I%%LOCALBASE%%/include -Wall -DNORMALUNIX -DSNDSERV -DSNDSRV # -DUSEASM
+LDFLAGS=-L%%LOCALBASE%%/lib
+LIBS=-lXext -lX11 -lm
# subdirectory for objects
O=linux
@@ -92,4 +93,4 @@
#############################################################
#
-#############################################################
\ No newline at end of file
+#############################################################