freebsd-ports/databases/py-MySQLdb/files/patch-ab
2002-09-10 07:52:20 +00:00

23 lines
772 B
Text

$FreeBSD$
--- setup.py.orig Thu Jul 18 22:55:36 2002
+++ setup.py Tue Sep 10 10:51:52 2002
@@ -11,7 +11,7 @@
NO = 0
# set this to YES if you have the thread-safe mysqlclient library
-thread_safe_library = YES
+thread_safe_library = NO
# You probably don't have to do anything past this point. If you
# do, please mail me the configuration for your platform. Don't
@@ -51,7 +51,7 @@
if sys.platform == "netbsd1":
include_dirs = ['/usr/pkg/include/mysql']
library_dirs = ['/usr/pkg/lib/mysql']
-elif sys.platform in ("freebsd4", "openbsd3"):
+elif sys.platform[:7] in ("freebsd", "openbsd"):
LOCALBASE = os.environ.get('LOCALBASE', '/usr/local')
include_dirs = ['%s/include/mysql' % LOCALBASE]
library_dirs = ['%s/lib/mysql' % LOCALBASE]